Sheet.ByNameNumberTitleblockAndViews does not place all views

Dear Dynamo enthusiasts,

I am having some problems with the “Sheet.ByNameNumberTitleBlockAndViews” node.

What should happen:
The node should create 60 sheets with a number of views (floor plans, sections and elevations) on each sheet (7-15 depending on the sheet)

What happens:
The node creates all the sheets, but sometimes only places about half of the views instead of the whole list of views. I will call the missing views “corrupt views” from now on.

What I have already tried:
I have been troubleshooting, trying to create only one sheet:

  • feeding the corrupt views one at a time into the node. This works.
  • feeding a list of 3 corrupt views into the node. This works.
  • feeding the whole list of views (good and corrupt) into the node for one sheet. This does not work. Only part of the list is placed on the sheet. Depending on the order of the list sometimes 4 out of 7 views are placed, sometimes 5. I get a warning message that a view could not be placed due to it’s size even though the view is small enough to fit on the sheet…
    warning warning2

For people who want the whole story:
In our project we have created views of every house (Floor Plans, Sections and Elevations). The house number is always part of the name of the view. We now want to create one sheet per house with all the views of that particular house on the it.
The script is pretty simple. I have an excel sheet with all sheet numbers, sheet names and house numbers. The script looks through all the views and filters them by name, containing the house number.
Input for the Sheet.ByNameNumberTitleBlockAndViews node is:

Use the Search button in the right upper corner, this question has been asked/solved many times

Dear @m.rijsmus,

I appreciate you taking the time to answer.

Off course I did take a look at other topics posted. However the problem seems different. I found several topics with people placing viewports that are too large for the sheet, but this is not the problem here, since I can run the script for a certain view seperately and it works, but if the same view is in a list together with other views, it is not placed. It also depends on the list order which views are placed, however it is not logical (for example, not the first items of the list). Therefore the view itself is not the problem. Also, if you look closely at the warnings, you will see that the viewport size is smaller than the sheet size.

Also I have found other topics that talk about list lacing, however this is also not the problem in my case. The lacing is correct. It runs through all the sheets and places several views on each one. (Not the same amount on each sheet, sometimes, sometimes 7) But for some reason it seems to randomely forget some of the views on some sheets. (Which as I said before, are small enough to fit on the sheet)

I know there are workarounds creating first empty sheets and then placing views on them, but I am stubborn and would really like to figure out what I am doing wrong that is upsetting this node.

If anyone is able to help, I would be really grateful.

Hi all,

I adjusted my script (I cut up my script into 2 scripts: one to create the sheets and one to place the views) and it works.
However I am still very curious as to why the Sheet.ByNameNumberTitleblockAndViews was not working consistently in my case. All viewports were smaller than sheet sizes and lacing was also correct as far as I could tell…

send the solved code screenshot for reference.


Thank you…

i hate these “use the search button” responses. sure the problem has been solved, but point the person in the right direction so then others in the future can find the right answer as well.

for anyone that is looking for the real solution to this problem, it is because either the viewport or something in the viewport is too large to be placed within the bounds of the titlesheet.

however… even if you have crop view switched on, sometimes you still get this error. if that’s the case, unload all revit links and dwg links/impoorts in your model/views and then run it again, it will work just fine. switch everything back on when you’re done.

Thanks Ryan! I am working on other stuff right now, but when I’ve got some time I am going to try this again with the dwg links switched off. I have a feeling you’re onto something there. I’ll let you guys know if it worked.