Setting parameter value by name on multiple elements



for some reason the Element.SetParametryByName does not seem to to work, what am i missing?

Already tried these:


Works fine on my end, first try.

What does the error msg/exception above the node says?

Maybe you have some junk mixed into the lists (ie. A non room in the room list, or non level in the level, list, etc)


And make sure you feed it actual Level elements as values and not string representations of the levels.


oh douhhhh… silly me… thank you


Hi everyone,

I’m trying to set a parameter value by name, however it’s placed in a linked model. Does any of you know if this approach is feasible without opening the linked model?

Thanks in advanced.

Kind regards,
Alejandro Mata


Hello dear friends

I have a question on how to accommodate data read from MySQL Workbench by Dynamo to a parameter of an object in Revit. I defined a sensor (specialty equipment family) in Revit model and attached it to a structural element. I also defined a parameter for this sensor such as DisplacementSetPoint to accommodate displacement data captured from the physical sensor. For this purpose, I linked Revit to MySQL Workbench through Dynamo to import sensor data from MySQL database to Revit. I created a Schema, table and a column in MySQL Workbench for importing sensor data from an external file like CSV file. I imported data to MySQL and read them through Dynamo as shown in attached pictures. For the next step, I want to accommodate these data into sensor’s parameter DisplacementSetPoint which has been already defined. As shown in the attached figures, I could read data from MySQL by dynamo and tried to import these data into Revit and attached it to the DisplacementSetPoint parameter of defined sensor using “Element.Set ParameterByName” node But it doesn’t work. Do you know how to set parameter by a list of values Thank u so much in advance.