Set Type Parameter

I’m working with Archi-lab_Grimshaw and it seems like “Set Type Parameter” Node isn’t working.

Any ideas of what I might be doing wrong?

Get works fine!

1 Like

Are you sure the parameter is a number? and not a string?

I tried both

Is it working fine for you?

Well, I haven’t used @Konrad_K_Sobon nodes for this unfortunately, but I’ve used the Rhythm node SetParameterByName and it works fine.



the archi-lab node is expecting a list if I am not mistaken.

Why not use OOTB-nodes? (Out of the box, nodes already included in Dynamo)


Pretty much what my Rhythm one does. :smile:

1 Like

This node only handles Instance Parameters.

It handles Type Parameters just fine, if you use the Element.Type node, like Einar showed :slight_smile:

If “Note d’identification” is the Type Comment Parameter, then it takes a string and not a number. Just FYI :wink:

What about set?

I tried this and it works. Great Script Martin_Spence1. Thanks, but I am confused.
Why you select an Element one by one instead o whole Family Type?
In another thread I asked for a node like yours but for change a “Type Comment” of a whole Family Type.
Maybe you know how. Thanks again