Separate Tabbed Window for Background Preview and Graph

Dear Dynamo Team,
Please consider to provide a separate tabed window for Background preview. It will be highly useful to invesitgate the geometry when dynamo is using for modelling. The idea is something like this

1 Like

You should probably make this request on the Github page, as that is meant for improvement requests for the software, whereas the Forum is for knowledge sharing and assistance. :slight_smile:

@Jonathan.Olesen,
I see. Thanks for the information. I will check that.:slightly_smiling_face:

Also if you’re building a graph in Dynamo for Revit this same method would apply - Revit on left (instead of Rhino), Dynamo on right (instead of grasshopper).

if you are adventurous:

3 Likes

Hi @JacobSmall,
I thought that way. But the problem is; although the dynamo will create a curve in revit it seems to me that Revit will not highlight point or geometry in Revit once we select any point from dynamo list. tile%20window

Correct - another request for the GitHub. :slight_smile:

Not so fast :slight_smile:

Hi @shefypattambi

It will highlight if you turn off all the previews on each node and on only the one which you need. Does that makes sense?

That would work, but it removes the context of the other geometry.

Elements (in Revit) will still be visible. Vocab matters. :smile:

Hi @Kulkul
You mean the point or geometry will highlight in Revit ?
I just recreated your suggestion and this is what I got. Nothing higlighted in Revit.

It will show in blue geometry or point.

I can see the blue curve. But could not find any point in revit.

Add Curve.Enpoint node after curve.Iso if you want to see endpoint.

Thank you for that tip…it is partially resolve the problem:grinning:
Do you have any tip to switch of the preview of all node at same time ?

@shefypattambi You can hit tab and right click hide preview or Select all nodes you want to hide right click node to code and hide.

Please mark the post as solved.

2 Likes

Hi @Kulkul , I recreated that procedure and this is what I am getting.

I would suggest you go through http://primer.dynamobim.org/en/02_Hello-Dynamo/2-3_the_workspace.html and learn the basics of dynamo. Your not following how i showed you above try to look closer and follow the process exactly. You have more than one node that have curves/Lines in it so you have to remove preview for all. Currently your turning off for only one. Does that makes sense?

Dear Kulkul.
Pardon me…I got it :star_struck: