Schedule View Fields shows null

I am working on a dynamo script that creates Pile Schedules (Structure Foundation Schedule) and filters them based on “Mark” Values for the Pile (Structure Foundation) instance,

the graph works well till the part of the Filter Assignment, When I try to get the “Mark” as a Schedule View Fields to use it for the FilterByTypeandValue, the Node “ScheduleView.Fields” shows Null as attached image.

Is there any explanation, Please?

I have tried a work around to reach the same results.
i have created a Foundation schedule with Mark one of its fields, and get this Field to feed the FilterByTypeAndValue" node,

Now the problem is that the “ScheduleView.AddFilter” shows a warning stating:
“The field ID is not the ID of a field in this ScheduleDefinition.
Parameter name: filter”

and here is a zoomed shot

See this post helps you?

Yes, the node works well except for my graph, and I do not know why.
Also, the other way of getting the same result as I mentioned later, The “Field ID” doesn’t get it to work.

if you could share the Graph along with sample file…I can try.