Room.finishes Areas

I’m trying to use the Room.Finishes node to find the exterior wall area of all of the spaces. I’m finding that I get good results sometimes, but not others

Using the script shown below, I get about 276 sq ft of exterior wall area. Taking measurements myself, There should be just over 400 sq ft of area on the North side. I’ve checked that the two walls sections on the North end are set to function as exterior.

Am I doing anything wrong here?


it looks like the rooms on the left side of your image are rooms without a boundary, no boundary no walls to recognize?

I deleted everything in this copy of the model except this area just to reduce the amount of data while I play around with it to figure it out. The results were the same when those rooms were bounded.

You could try this

Keep in mind that the boundaries of the Room are always in clockwise order.
So what i did was take the rooms, explode the solids, take the surfaces that came from the solids, made a vector pointing in the direction of the normal in the middle of the surface.
Now you just need to filter out the Rooms, do the above, and filter out the north facing surfaces
You need to switch on the volume computations option for the Rooms

I figured out my problem. I didn’t realize that ceilings would restrict the height of the room even if the room is manually set to be taller. I’m setting them above the ceiling for heating/cooling load purposes. Works great now. Thanks for the suggestions.

1 Like