RevitPythonWindow 1.6.0 - installation problem

I’m trying to install the RPW package and I’m not having much luck.

Install via Dynamo or the Package website results in an empty directory structure for the 1.6.0 version. There should be some DYN and DYF files in the package folders, right?

The 1.3.1 version seems to work correctly; so it looks like there is an issue with the latest version.

Thank you for pointing this out, I will take a look at it.
Ps;I’m assuming you are referring to Revitpythonwrapper, correct me is am wrong!

Hi @Adrian_Esdaile

In case if you missed here is the link to install RPW

Hi @Gui_Talarico,

Yes, I am referring to Revit Python Wrapper as downloaded from the Package Manager inside Dynamo and the Dynamo Package website. Both sources provide a small directory structure and the package json file; but the directories are empty.

The Zip version from the website is also empty of any files in the directory structure (no DYN or DYF files)

Just to further clarify - this is for the 1.6.0 package. The 1.3.1 package appears to load the correct files, and contains the corresponding DYN & DYF files.

Hi @Adrian_Esdaile - Not sure if 1.6 was working or not,
but just published the latest 1.7.2 and installed on a new machine and it seems to be worked fine here

Installing the packages loaded the files at the desired location as expected:
"C:\Users\gtalarico\AppData\Roaming\Dynamo\Dynamo Revit\1.3\packages\RevitPythonWrapper\extra\"
"C:\Users\gtalarico\AppData\Roaming\Dynamo\Dynamo Revit\1.3\packages\RevitPythonWrapper\dyf\RPW_GetFilepath.dyf"
"C:\Users\gtalarico\AppData\Roaming\Dynamo\Dynamo Revit\1.3\packages\RevitPythonWrapper\extra\RPW_GettingStarted.dyn"

If it doesn’t work for you maybe try clearing out any left overs in the packages folder

Hi Gui,

Yep, that (1.7.1 / 1.7.2) worked. Something strange must have happened to 1.6.0.