Revit model not getting updated as per the dynamo graph

revit
mep
excel
dynamo

#1

Hi all,

I’m trying to size the pipe of Domestic cold water system, based on the fixture units. I’ve an Excel sheet in which all the fixture units and the required sizes are listed. I tried running the graph for a small model and it worked perfectly. However it’s not working as it was intended to be when I run it on a bigger model.

When I check the watch node, it looks like the dynamo is working perfect, but the Revit model is not properly responding.
Even though I’ve filtered out all the other piping systems except cold water system, in some places the size of hot water pipes gets changed (currently I’ve only 2 systems in my model, i.e. Hot water & cold water).

Also the size of the pipes are not getting changed as per the dynamo graph.

This is the graph i’m using.



Could you please help me to figure out what is going wrong…?
Thanks in advance.!


#2

You’re setting the values for your original unfiltered list. I’m guessing if you input the filtered list everything will update correctly.


#4

You were right @Nick_Boyts. Thanks a lot. ! Sorry, as i’m s beginner, took time to understand what you said.