Revit 2020 / Dynamo 2.1 / Refinery

Hello,

I just installed Revit 2020, with Dynamo 2.1. I watched one of the videos from Autodesk about it " Revit 2020: Dynamo 2.1 Ships with 2020"

From that video, it seemed like Refinery would be part of the Dynamo 2.1 install (or maybe Revit 2020 itself?) However when I ran Revit & Dynamo there was not Refinery installed.

I went to the Refinery beta site to download it but, it seems the latest version available there (0.4.44) is only from Dynamo 2.0.2?

"* Revit 2018.3, Revit 2019.0, or Revit 2019.1

  • Note that Dynamo keyboard shortcuts are disabled in Revit 2019.0. For instance, Ctrl-S (File Save for Dynamo for Revit) will not work. This issue is fixed with Revit 2019.1. If possible, we suggest that you upgrade to Revit 2019.1 for a better user experience.
  • Dynamo 2.0.2 for Revit or Dynamo Sandbox 2.0.2
  • YourLogic.dyn that you want to optimize"

Did I miss something during the Revit 2020 install, or will this feature be added later?

Thanks

Carl

Try installing Refinery again via the beta site as it may work. If not try to copy the contents of the package folder from your 2.0.2 install over to your 2.1 directory. Best to move it into both sandbox and Dynamo for Revit (assuming both exist - I haven’t gotten to Revit 2020 yet as it hasn’t hit my account yet). Let me know if that works so we can spread the word.

The Refinery development team is aware of the issue.

Okay I removed Refinery and reinstalled it with Revit 2020 already installed, and still no go in Dynamo 2.1.

I then copied the Refinery package contents to the 2.1 directories in both Revit and Core folders. When I opened Revit 2020 and Dynamo 2.1 I know see the Refinery is installed.

However, when I try to run Refinery I get this error, then Dynamo 2.1 crashes.

2019-04-14_21-42-39

Thanks for looking into this @JacobSmall and for passing it along to the Refinery development team.

Carl

1 Like

Hi Carl, Thanks for the note. Unfortunately, our video is incorrect and Refinery will only work on Revit 2018.3, Revit 2019.0, Revit 2019.1 or Revit 2019.2 for now. There are incompatibilities with Revit 2020 CEF version. We working on a solution so stay tuned and thanks for your interest in Refinery!!

5 Likes

Hi, I am trying to use Refinery on Revit 2020 - But its prerequisite is Dynamo 2.0.1 and I cannot seems to make Refinery works with Revit 2020 and Latest version of Dynamo.

I am just curious, if there are any update on the Refinery support for Revit 2020

Hi Jacob, has there been any upgrade after this post? Do you know if Refinery is available for Revit 2020 / Dynamo 2.1 ?

Thanks

Our latest release of Refinery 0.9.4 does now work with Revit 2020. Is this the version of Refinery that you are trying? Please let us know if you continue to have issues and we’ll try to help sort them out.

1 Like

Thank you so much Lilli. It was the version. Now it is working.

yay! Let us know what you think!

Lilli,
I’m still having the CefSharp.wpf problem with launching refinery with Revit 2020.1 and Dynamo Core 2.2.1.5175 Dynamo Revit 2.1.0.7733
Can you help me ?

Impossible de charger le fichier ou l’assembly ‘CefSharp.Wpf, Version=57.0.0.0, Culture=neutral, PublicKeyToken=40c4b6fc221f4138’ ou une de ses dépendances. Le fichier spécifié est introuvable.

à RefineryViewExtension.RefineryClientWindow…ctor(RefineryViewModel vm)
à RefineryViewExtension.RefineryViewExtension.ShowClientDialog() dans D:\Git\RefineryExtension\src\RefineryViewExtension\RefineryViewExtension.cs:ligne 126
à System.Windows.EventRoute.InvokeHandlersImpl(Object source, RoutedEventArgs args, Boolean reRaised)
à System.Windows.UIElement.RaiseEventImpl(DependencyObject sender, RoutedEventArgs args)
à System.Windows.Controls.MenuItem.InvokeClickAfterRender(Object arg)
à System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
à System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)

Best to ask this in the Refinery beta forum. I’ll flag Lilly and the team all the same.

1 Like

Hello,

I had your problem.

Trully, the problem is in the dynamo window’s location.

Try to click the right bottom of your mouse and choose the option “maximize window”.

Hi @Mah_torre
Tried to maximize window and didn’t work…

So I really don’t know your problem. Sorry

Did you ask on the beta site?

I did, Nate is trying to help me but all the solutions didn’t work :pensive:

That’s going to be your best route forward, which is why I brought it back up. Nate may have already had you try this or it could be a waste of your time entirely (we don’t even know how you are launching Refinery: via Dynamo Sandbox, Dynamo for Revit, or via Revit), but based on the fact that you are seeing a CEF issue, try the following two possible solutions:

  1. Shut down Revit and any other ADSK software. Remove all Revit add ins. Remove all Dynamo packages and view extensions except Refinery. Restart Revit and try again. This is an attempt to see if it’s a customization which is causing the bad state. If so then you can slowly add them back in until you find the offending piece of the puzzle.

  2. uninstall Refinery and Revit 2020. Reinstall Revit, and the updates, to your C drive. This will fix any bad installations which may have corrupted the version of cef which is being fetched. Fortunately in 2020 the Dynamo build will reinstall as well at that time. Reinstall Refinery to your C drive and try launching it. If it works it may have been a bad install or an unsupported path (ie: secondary hard disc drive) - this would fix both.