Revit 2017 & Room Boundaries

Hi, new to the forum here. I’ve been teaching myself Dynamo for the last couple of months now with some good success.

I recently upgraded to Revit 2017 SP 2 (and Dynamo 1.1). I’ve been using the Room.Boundaries node from the Clockwork package to get curves from the rooms so I can make 3D Rooms, floor finishes etc. Now when I run the same script the list of curves is coming back empty. It’s like it doesn’t recognize the room boundaries anymore.
I’ve also tried the room.boundaries node from the archi-lab package as well and get back the same empty list.
I went back to Revit 2015 with Dynamo 1.1 and the node runs perfectly fine, so I think it is probably something to do with Revit rather than the new version of Dynamo (but I could be wrong)

Has anyone else come across the issue yet? Or if they know how to fix it that would be even better :slight_smile:

Hi Deborah!

Can you expand (double click) the custom node and copy/paste it to your graph, rewire, run and take a screenshot that includes the wanings you get (hoover over the yellow bubbles)

Hi, thanks for answering. I’ve been working on doing just that. I’ve expanded the Clockwork Node and copied/pasted it across. I don’t get any of the yellow pop-up warnings. I should get two lists back - one for the rooms, and one for the curves. The list rooms comes back fine, but the list of curves just shows up as empty - see attached screenshot (hope it’s legible, this is my first time adding in an image!) When run in 2015 it’s fine, but 2017 it comes back empty.

Looks like the curve property has been substitued with a GetCurve() method in 2017,
and the Element property is now ElementId

Open the python node and try to replace Element with ElementId in line 27 and Curve with GetCurve() in line 28



Thanks for the help - I tried changing the python script but that didn’t seem to work. I don’t know enough about Python to be able to figure out what could be wrong in it, or how to fix it.

You have to change line 27 aswell, I just updated the last post.

That works, thanks so much for your help :smile:

I am having the same problem, and having looked into the solution from Einar_Raknes, it looks like the current version of the Clockwork node tries to account for the changed commands. I still get null elements and empty curve lists. Any ideas?