ReRun the definition without changing parameters

Hello Everyone,

I have a simple definition which exports the Revit Model as an FBX file. The file exports the first time. However, every time I make changes in Revit and try to export by clicking the “Run” button, nothing happens. Unless I change something in the dynamo definition, I cannot hit the run button again and have it save the FBX file. I tried by creating a python script that gets the time and outputs it to another function, but the python battery with the time function wouldn’t regenerate the time. Is there a hack around this ?

Thanks in advance !

This is an issue with Dynamo’s live runner finding no new computation to be done, for now, I think you’ll need to unhook something, run the graph, and rehook a node. This is something that could be solved by writing a node that explicitly dirties the state of the graph when it is run.

is there working solution for problem yet? it is kinda insane…

Try to run your node using dynamo player or Dyno browser