Rebar By Curve Empty List...Why?


#1

Why is the rebar by curve node returning an empty list?


#2

Why do you send your “curve” input through a List.Create node?
That might be the issue here, as you’re putting it into a “deeper dimension” here.


#3

I have tried all connection approaches, but it still returns ‘empty list’.

Here is the result from my first of many approaches:


#4

Even in this state you’re not sending in a flattened list into the curve input. Maybe try to let the Flattennode be the last modification before you send the list into the Rebar.ByCurve node.


#5

If the image below is what you are thinking, then l have tried this approach to.

It makes no sense.


#6

Then I don’t know either, that was just something weird I happened to notice.
I can only tell you that there’s a wrong input somewhere, and considering you’re not getting warnings but an empty list I’m thinking the issue is somewhere with the dimensions of some inputs, but I don’t know the Rebar.ByCurve that well and I also lack oversight in your script.


#7

I agree.

Bizarre.


#8

This empty list was causing an issue l think:


#9

But do get an error now…


#10

Well, that’s annoying, but it can be fixable. First off all: check if all the inputs are indeed of the correct type, I’m guessing that’s probably fine.
It might be the issue that it doesn’t like that you’re sending in lists into some inputs and single inputs into others. I think the issue might actually be the same as the one I thought the original problem was: meaning you’re sending a list of lists into the curve input, in practica that should mean that the other list inputs should have a similar structure (I think) which the “vector” input at this point certainly does not.


#11

Host Element ID was not an Integer. This was the issue.

Many thanks PauLtus


#12

Well, that stuff happens.
Please mark whatever comment you think counts as the solution as the solution (might be your own) and maybe leave a like on other helpful comments.