Problem with Extracting Insulation Thickness parameter values

Hello guys

I am extracting different parameters from a Mechanical Revit model. I could extract all parameters properly except “Insulation Thickness”. It gives me zero value for all of them, but I have some elements with non-zero insulation thickness value. It only happened on Duct Fittings category (Please see the attached pics). For other categories such as Ducts and Duct Accessories Dynamo could extract the right values of each element. I used the same workflow in my script. As I said, for Ducts and Duct Accessories it worked, but for Duct Fittings it does not work. Do you know where the problem is? Thanks :slight_smile:

Have you tried fabrication parts?:

1 Like

Thanks @Schasfoortyoeri for your response, but the category I am checking is Duct Fittings. It works for all other categories and I could extract the insulation thickness of their elements, but I do not know why for Duct Fittings category, it doesn’t work and it gives me all values equal to Zero. Do you have any suggestion?

Could you upload a dummy project? i do not have much MEP content like fittings and stuff

If i lookup Revit API it should be DuctInsulation

1 Like

I found the solution.
I used MEPover package and It worked.

Thanks :slight_smile: