Place Generic Line-Based Family by FamilyInstance.ByPoint - Odd Result

Hello Dynamo Community!
I’ve found that FamilyInstance.ByPoint works great with families except when I use a Generic Line-Based Family. The result is that the node only places the family respective to the Z-value, but defaults X and Y to 0. Other families have worked correctly and I do have a work around, but would be nice to solve this. Screenshot below. Can’t upload revit files because I’m new to the group apparently. Any help on this would be awesome!

Grasshopper user for 6-7 years but found there’s a lot similar here. Definitely have a lot to learn but excited to join this forum!

Hello, you tried to activate the product long (3 Points)


Likely you want to use the node FamilyInstance.ByCurve from the clockwork package, or a similar custom node, as Line-Based means you need to provide a line to define the shape correctly.

@jacob.small thanks a lot. See you on the forum quite a bit so thank you for your time. So that makes sense, but unfortunately there’s a “level” input and the curves I have are not always on a particular level (stadium project). Any ideas on how to bypass level input?

Always happy to help others learn Dynamo the way people helped me all those years ago… Pay it forward and all that. :slight_smile:

These appear to be stadium seat lines of some sort; I’d likely try to use the entry level for that segment of seating. For now what happens if you put in level 1?

PS: Checked my admin account, and it looks like your reply + the time spent browsing the forum bumped your trust level, so you should be able to post files now. If you’d like to share the file now it may work, and if not let me know and I can bump you.


@jacob.small - apologies for the delay but thank you for the continued help. I got a script working that does what I need it to do but would still like to use the “Generic Model Line Based” rather than just the Generic Model Family I’m using with an array instance parameter. Still can’t post a simplified revit & dynamo file because of size limits but I posted a gif of what my end result looks like and a jpeg of simplified script. The FamilyInstance.ByCurve actually returns null but the FamilyInstance.ByLine gives me a result. The seating is placed on a singluar level as expected whereas I’d like to place the seating per curve’s elevation. Fun problem. I really went into the multi-verse to develop this script and wouldn’t dare share because I’m sure it would give you nightmares hahah.

Stadium Small

Can you post the family? If not here than in another location? With that we can build a quick ‘sloped surface’ and place the family along the isocurves, which will give you a good example for how to place the family.