Part Type from "Specialty Equipment" and maybe others

Hi:

I been trying to get the values from the parameter “Part Type” in “Specialty Equipment”, I tried “MechanicalFitting.info” from MEPower but its only working with “Pipe Fittings” also tried “GetParameterValueByName” but nothing. Any help?

Are you trying to access that parameter from the family document or the project document? I believe the only was is through the family document with Python.

From the project, because I need to get the same parameter from Pipe Fittings, and others… that´s the point we don’t want to open all the families for check that info.

It’s a parameter of the family. You need to get the family from each instance and then query the Part Type parameter.

Nick, I’m at this point:

How can I turn the numbers into the string I need?

Thanks.

It looks like the lower node is returning everything correctly. The numbers you are seeing are the indexes of each of the members within the PartType Enumeration

The first 6 numbers in your list are 0, which corresponds to the first item in the enum (“Undefined” in this case). Likewise, the member at index 9 is “Cap”.

Your “Part Type” for the specialty equipment family says “Normal”, so the number should actually be 1 instead of 0, but I’m not sure why that isn’t the case.

1 Like

It seems that “Normal” and “Undefined” corresponds to 0 and them DuctMounted starts in 1, that explain why Cap is 9 and elbow is 5

Thank you, for the info.

1 Like

It may be that Undefined is -1 and Normal is 0. The MechanicalFitting.Info node is probably returning null values because your Specialty Equipment families are not duct or pipe fittings. It should be rather easy to get a node to return “Normal”, but it will most likely have to be done in a Python node using the Revit API. I can try to do some testing tomorrow.

1 Like

Thank you:
I tried with Python but I don’t have enougth experience with the API… or phyton :sweat_smile:

Thanks for all.

Would you be able to upload your .rfa or even a stripped-down version of it? I can’t seem to make a Specialty Equipment family with a Part Type parameter.

MEPover has a node GetParameterAsValueString which will return the user-facing value instead of the corresponding number.

2 Likes

oh god…it works … I was cheking with a big list XD, but this way is better.

@cgartland the code block of Nick fixed the proble, but if you still want to try here is the .rfa file.
Thank you for all your help and attention.

I see. You should be able to mark his post as the solution so other users may find it in the future. Cheers