Overlapping Dimension String Texts

New to the forum and i was searching for a code for adjusting dimension string texts to clean up automatically similarly to what the code in the video does below. I saw some old posts that do not work anymore with Revit 2023. Any help is appreciated! I appreciate your patience with me posting this also in case it’s been covered hundred of times already! Thanks.

The script I provided in my response in your other post works in 2023.

Unfortunately it has many error messages that do not work for me.

Based on your clip, the node colored red indicates that you do not have the associated package installed. That node and other nodes within the script require the rhythm package to be installed. Once you install that package, the script should work.


Unfortunately that package is already installed and it is still giving me that error. Not sure what I am doing wrong in this instance.

I now see and realize that you did have rhythm installed. Apologies for the misguidance. Please list out what the errors are stating.

When i hit install specified version it gives me the same message that it is already installed so i’m unsure why it is even giving me that error. I placed snippets of all the errors i see. I know this is alot so i appreciate you helping me figure this out!

You may need to make sure DynamoIronPython2.7 is also loaded, but I can’t confirm that. Hopefully someone else can provide input on those errors.

It is loaded but it is still giving me issues.
I appreciate your time!

@cromeroPVB2L i also came across this issue recently please start the installation and it’ll not be able to do and it’ll say that {Package name} needs to be uninstalled to install this one.

Make a note of what package is creating this issue and then close dynamo go to package folder deal with that package and you’ll be able to install Rhythm as it’s having some conflict coz of dependencies.

if u still couldn’t resolve please get in touch with @john_pierson He’s the right person to help u with the exact issue.


I appreciate the response. I just tried this method again and it does not resolve my issue. It is frustrating but I reached out to John. Thank you!

Try this. Search for the List.GetItemIndicies node in your Dynamo search-bar and see if that node shows up in the list. If it does, then replace the one in the graph that is giving the red error. Then try running the graph again. If that node does not show up in the search, then close Revit. Go to the packages folder and delete the Rhythm folder completely. Then go back into Dynamo and re-install the Rhythm package. This step may be what @bharat.minocha was suggesting you do.

Or last resort, close Revit and place this dyf file in the packages > Rhythm > dyf folder.

List.GetItemIndices.dyf (8.0 KB)


I attempted the last resort you mentioned by placing the dyf file specifically into the folder and that worked! I really appreciate your help. The only file i need now is the file for this guy here. Its probably living somewhere on the forum but I was hoping you could direct me to it or if you could just send me it. I really do appreciate your help!

That’s a Rhythm node as well. Sounds like you have discrepancies between packages or Rhythm didn’t install correctly. You really need to resolve that or else you will be constantly dealing with this on all of your scripts. Rhythm is a highly utilized package when developing scripts. I would recommend deleting the folder and re-installing Rhythm package as previously suggested. Make sure you are picking the correct install for your Revit/Dynamo version.

1 Like

Pasting my reply from the DM here as well:

1 Like