No parameter found by that name when drawing Beams

Hi there, I have a question about my new Dynamo script.
When i run my script i get the message that no paramater was found by that name.
I’m trying to draw beams (structural framing) by only using imported values from Excel.
I will give you a few screenshots of my current Dynamo script to give you an idea how.

  1. First i draw a line from point to point generated from excel, which turns into a Beam.
  2. Secondly i import the parameter values from excel which i need for the cutback value parameter.
  3. At last i try to adjust the parameter value which gives me the error as mentioned above.
    image

This problem is solved when I run the script once, to draw the beams. Then adjust the script by adding some watch nodes, and run it again.
But i can’t get it to work to run it in one time without warnings, I hope someone can help me out on this one.

The Script is quite large with other components which i prefferable don’t want to share.
Thanks in advance

If you get this message it often means that you haven’t insert the correct parameter name in your node.

It can also be the […] that cause the problems you don’t need to add these.

1 Like

@hugo.paalman Thanks for your quick reply!

I removed the brackets but it didn’t seem to make any difference. still get the same error.

The parameter name is correct because the script works every now and then.
When i remove the watch node after a first run the script works for a second run.

If I restart Revit and run the script again i have to add the watch node after the first run to make it work again.
Somehow Dynamo can’t find the connection to the parameter name of the beam after only one run?

1 Like

@Bjorn_Keulemans1 Thanks for your quick reply!

Flattening the list and removing the brackets doesn’t make a difference for me. (Thanks for the tip though, it will make my script a little bit more clearer)
What do you mean exactly by making a list? Just create a list with 4 code blocks “End Join Cutback” going in?

And again thanks for you help!

Putting square brackets around something means you’re putting it into a list.

Look at the difference between putting 1…5 in a code block or putting [1…5] in a code block.

With the SetParameter Nodes you don’t need to put the name of the parameter in a list, even more so if you only have 1 parameter.

Without something to test getting to the cause of this is hard, but there might be some issue with the script both making the Beams (creating an ID) and changing the element at the same time. You could try to introduce a Passthrough Node (Clockwork) between the section of your script generating the actual beams and the section of your script changing the parameter values.

1 Like

Thanks for clarifying!
I adjusted the code blocks as you said no difference for the end result of this script but still something I should adapt in my other scripts, thanks!

The last alinea was exactly the thing i was thinking about. therefore i ran everything through the create list. Is this sufficient or should i still look for a passthrough node? (will definitely try is)
I could cut a piece out of the script so i could upload that if the passthrough node should not work.

Do the beams have that parameter available in Revit?

@JacobSmall
They do have the parameter so it should be fine.
But the paramater normally appears when beams intersect with each other right?. Maybe Dynamo can’t find the parameter that quick?

@Bjorn_Keulemans1
I used a passthrough node from the Clockwork package but it didn’t seem to have any effect yet. I’ll try to do some more tests the passthrough node (place it in different places).

@Sven_de_leau sven

I have basically the same problem…

It seems like Start Join Cutback and End Join Cutback parameters are only created in Revit after running the script… Thats my idea.

The Start Join Cutback and End Join Cutback parameters are not visible after first run of Dynamo script however they exist in Revit. After second run (just re run it without any changes to script) everything works - but is there a way so it worked in the first run?

Did you find any solution to this?

I also tried passthrough node and nodes/scripts that dissallow joining - all for nothing.

Maybe there is someone elso who found a solution for this?

Regards

Dear @bartdevil1984

I didn’t found a solution with the standard nodes available to Dynamo. There is package though named: StructuralFraming.DisallowJoins which seemed to work fine for me. I currently don’t use this script anymore so I am not sure if the custom node still works.

Cheers,

It works for me! Thank you so much!