No parameter found by that name_BIM4struc

Hey everyone,

I have error named “no parameter found” in the below attached script. I have created a family of 2D bridge section which I am trying to place at certain points (obtained from civil 3d). Any suggestion on the same error will be helpful.

Thank you in advance

which means there no parameter in Revit as per given inputs. check the given parameters (Case-sensitive). Try one by one.

Edit: Need to add


Hi @karankool7568
Maybe verify your input into SET node, actually is a family type, try fedd instances.

Hi @karankool7568,

You are feeding in a Revit Family Type (and its Parameters) instead of Elements of that given type, try creating your family instances first and then setting your parameter values to those instances.

Thanks for the response @_Vijay. But adding family type is creating same error.

One more thing this is error I am getting when my family is created using lines imported from CAD. I have tried the same method but with creating the family in revit only and surprisingly this time it doesn’t create any error. So is the error because of import?


still you feeding type element. you need to feed instance as show in the above post.

if you import the cad you better convert to the Revit element inside the family.

But when I am feeding instance it is creating the error, moreover initially I am feeding certain parameters and later the rest.

Does line properties does also needed to be converted? As all I am importing is 2D line feature.

So, Line have all this parameter?

if its check its a type parameter or instance?

I think so it is parameter type but not 100 percent sure. I am sure that its dimension lines are instance type (part of revit family).

How to check if a line type is instance or parameter?

Well aren’t this used for checking dimension line type?

I have created “instance type” for the dimension line.


Can you share your files? .rvt, .dyn & .dwg