Monocle and Package usage doge

Using Revit 2021.1, Dynamo Core, Dynamo Revit, Monocle v.2020.10.1.0
When using the ‘Package usage doge’, “Send Package Usage to Clipboard” command, I don’t get the version numbers for the packages I’m using…
Anyone seen this before & do you know how to fix it…?

Many thanks for your time and help

Hi @DoubleG ,

I actually was about to make a similar post to this as well last week but I forgot about it.
I found out that this happens when your Dynamo Packages are stored somewhere else than the (standard) Appdata/Autodesk location, i.e. a central cloud location.

@john_pierson probably also want to hear about this.

1 Like

I’ve actually noticed this as well and have tried to fix it in the most recent versions can you try the newest version and report back?

I also think I will begin looking at the ootb ways of getting versions. Back when I first made the tool there was no way to get versions so I had to make my own. :sweat_smile:

1 Like

Hi @Daan,
All my packages are saved in the …AppData\Roaming\Dynamo\Dynamo Revit\2.6\packages folder which I think is the default location…

I’ll try what @john_pierson is suggesting, see if that works

Hi @john_pierson,
I’ve just installed the latest version of Monocle that will work with our version of Dynamo…
Same result I’m afraid…
You mentioned

Might sound like a silly question, but is that ootb way within dynamo…?

@john_pierson and @Daan,
Thanks for your help.
I’ve just fixed it…
Made sure the top path within the “Manage Node and Package Paths” is …\AppData\Roaming\Dynamo\Dynamo Revit\2.6

In …\AppData\Roaming\Dynamo\Dynamo Revit\2.6\ packages
There was a subfolder called packages where “monocle” was sitting, I removed that subfolder (make sure Revit and Dynamo are both closed)
Reinstall Monocle, restart Dynamo, now you should be able to get the version numbers

Hope this helps someone else

1 Like

Very cool. Thanks for reporting back.

I ended up revising my code to use the OOTB way now. This should work regardless of where your path is now. I was initially targeting the AppData location exclusively.

Code here, and tested it for Revit 2019-2023.

I will be pushing the update soon.