I’m using the ModelCurve.ByCurve node to pass a group of lines into Revit. Unfortunately when I change the inputs to create a new group of lines the previous lines are deleted.

Any ideas how this might be prevented?

Hi Mate,

If I have read the question right.
You need to close the script and open it again. Or run it thru dynamo player or Dyno App. Dynamo doesn’t lock things in each time u run it, which allows you to keep changing stuff on the fly.

Kind Regards

Hi Andrew,

Sorry for not getting back to you on this. I’ve found a work around that is to close Dynamo each time I run the script which solves the issue. I have a very large model with thousands of model lines so what I plan to do is to test in an empty model and see if it’s related to model size.



I suspect that when the node converts from Dynamo to Revit elements, it is setting ToDSType(False) in the transaction, which means it is still bound to Dynamo… I tried a script which set this to True, but it didn’t seem to help. Closing and opening Dynamo was the only way for me to break that connection.

Instead I took the method in this thread and swapped it around… It seems happy enough doing different curves in the same graph now…

ModelLinestoDetailLines.dyn (4.0 KB)

Hope that helps,


1 Like

Hi Mark,

This code seems to want detail curves as the input, not model curves which is what I’m using…

Hi @BIMused

That’s normal behavior for OOTB nodes. But you could use python to create ModelCurves by using Create.NewModelCurve method in API

Hi @Mark.Ackerley

I think you have misunderstood his query. He is looking to create Modelcurves by curves. See my action above it will help you understand.

Here is the dyn file Create Model Lines (ForTom).dyn (31.3 KB)

1 Like

Thanks but is it possible to remove the sketch plane input[1] since I’m creating lines directly into a 3D view for non planar geometry?

@BIMused Not possible.

Use plane.ByOrigin node for 3d views:

Mark the post as solved.

Seems the issue I have is that the python node expects a single plane (no index numbers) where I have multiple planes…don’t know how to remove the index numbers, see below…