Mleader Difficulty

Struggling to create Mleaders with Dynamo and Civil3DToolkit 1.1.28.

I’m getting the data I want from the surface but having trouble passing to the Mleader.

I’m not understanding what it wants for Object so its triggering an error. Essentially it expects Autodesk.AutoCAD.DynamoNodes.Object and is getting Autodesk.AutoCAD.DynamoNodes.Polyline.

Can anyone explain what this .Object is? I have not been able to find that out.

Here is a screenshot of my very messy graph. Thanks for your help.

The way I’ve used that node is by selecting objects that have a single base point like a block, circle, or point, and the mleader will be used to label those objects.

Thanks - I will give it a try. I appreciate the suggestion.

It looks like you can use polyline objects as long as you then feed a single point like start point into the “point” input, like you are doing, you just need the raw object to go into the “obj” input.

That was the part that was confusing me. I also tried feeding it the start point but it wouldn’t accept that as well.

Any ideas?

Perhaps use object.gemetry instead of arc.geometry

Thanks again, I had tried that configuration but I couldn’t get it to work. So I erased the node and re-added it and it seems to be working.