Understanding MLeader Nodes (Civil 3D Toolkit)

Hi, I am trying to understand the MLeader Nodes from Civil 3D toolkit, little support in this will be really helpful. (Bellow Image)

  1. A civil 3D Leader is selected and tried to get the Text associated to leader but getting Null in return
  2. Selected a Object and tried to create a Leader from ObjectText (expectation of Leader (Red) but Getting a Leader from Dynamo (White) ) Even after Displacement vector kept as 0,0,0.
  3. Tried creating a leader using a Block but its placing is really far from the object for vector 0,0,0.

I am sure that i am not using the Nodes correctly so expecting a support in creating a graph to get expected result.



I get the same result in my tests. Probably good to log this as an issue on GitHub.

It’s hard to see the entirety of the object (white line) in the screenshot, but in my tests it looks like the insertion point of the leader is placed at the geometric extents of the input object (i.e. center of the bounding box).

I do not get this behavior. Maybe check to make sure that the insertion point for the block is where it should be.

FYI I logged an issue on GitHub suggesting an improvement to add more nodes that enable controlling the leader insertion point with a Dynamo point instead of an AutoCAD object.

1 Like

@shahid.shaikh_C3D you could try the nodes I included in Camber.

MLeader

@mzjensen Thanks alot worked perfectly as intended.
adding screenshot here for future use…

Suggestion:

  1. I am not aware how the things work in background coding but if you can please align it to take input from C3Dtoolkit nodes too then that will be a great advantage.
  2. In future we can have a nodes to change arrow headsize, text height, rotation etc.

I understand where you’re coming from, but there are a few technical reasons why I can’t do that. Sorry. More explanation here:

I’ll add it to the list! :+1:

1 Like