Missing package? or installing Problem, dynamo?

Hello Dynos,

I have always the same problems… i use dynamo 2.0.3. i do not find the correct packages.
Sometimes i open dynamo, it worked and sometimes not.

So what is the correct packege?

And what could be a workaround?

The script are created in 1.3.4. and can just open it only in 2.0.3. right now.

I glad about any adviseTest.dyn (166.4 KB) Sorry, i can’t upload a demfile… it is too complex.



Hi @Draxl_Andreas,

The nodes come from the archilab package. The last version of Archilab running on Dynamo 1.3.4 (2018.x.x) now has big differences with the last update of archilab (2021.25.7) running on Dynamo 2.X. You must therefore drop the Element.Type and Select.ByCategoryAndLevel nodes again and delete the old nodes.

it is a tricky script, first part should be collect rooms from linked file, it does not work!
workset is on, linked file is loadet, i got it listed, but i can`t get the rooms :confused:

The Element.GetFromLinkedFile is a old node with a redundant input.
Use instead Get All Elements From Linked Model, Collector.ElementsOfCategoryInDocument, ꟿ Collect.LinkedInstanceElements or SelectByCategory in Document nodes.

1 Like

I reopend revit, and placed the node again, … it works

a solution(?)

the sorting part finaly, i do not unterstand.

there is final part that i do not unterstand, becaus it seem to be the some nodes disappeared.
(F.E. the boolmask, has just the mask!
Element Types, they not continue)

… i solved it with a older version of archilab (2018)