Make Floors boundary invisible in a certain views

Hii All,
I’m trying to make a dynamo script to override the boundary lines of floors to be invisible like we do when using line work tool in Revit. but the nodes that override the graphic settings are using line patterns to override the boundary not the line styles " Invisible Line"

  • I know that there is a trick which overrides the line color to be white but those lines still visible in printing so this workaround is not effective.
  • Also i know that we can use parts to make the boundary of floor invisible but i don’t want to use parts overall.
    I’ve searched a lot about this issue but with no luck.:confounded::confounded:
    Is there any way to apply linework tool to floors boundaries in view and override them to be invisible ??

Why not use a View Template and turn off the Slab Edges under the Floors category? Or you could even override it here.

image

thanks for your answer , but this way doesn’t work unfortunately

Try to use the OverrideGraphicSettings.ByProperties node.
Similar to the one in the video tutorial by @john_pierson on YouTube:

Problem is that invisible lines can only be utilized with the line work tool, and in detail sketch elements. Overriding to nearly white (values of 254 or so) May be the best option available at the moment.

The Slab Edge Subcategory under Floors is referring to the Slab Edge component, not to the floor edge line.
I am afraid that the option proposed by @JacobSmall is the only one. However, make sure you select a specific colour for the floor pattern, under the V/G (If you have applied) projection pattern. Otherwise, if you select a pattern but the colour is set to “No Override”, the pattern will be white too.