Libg.protointerface.dll Issue

Hello Guys

I Know there are some Topics about this issue but in all of them talking about intall Revit or Formit like a solution.

I have installed Revit, Civil, Navisworks, Inventor and others. When I installed Dynamo Sandbox 2.16.0 and tried to use a geometry node (point), Dynamo shows this message:

Regards

The geometry engine for 2.16 utilizes a new libg which is has not yet been released publicly; this engine was put into place to allow some nice new geometry tools, but it requires an update to the core nodes. Look for a Revit (or similar core product) release in the coming months which will provide the necessary dependancy.

For now Dynamo sandbox 2.13 should work fine.

1 Like

I ran into this as well, with a graph created in 2.15.0 sandbox. Looks like in 2.16.0 the LibG.ProtoInterface.dll file used in 2.15.0 (and earlier) has been renamed to LibG.Interface.dll. (That is my best guess, anyway.) I thought I would go ahead and just add the geometry nodes from 2.16.0, but those throw the same error message, even in a new graph.

I threw caution to the wind and renamed LibG.Interface.dll in the 2.16.0 files. That resulted in an unhandled exception, reminding me that throwing caution to the winds often has bad results.

Changing the name back to LibG.Interface.dll allows 2.16.0 Sandbox to open. I will stick with 2.15.0 for the time being, and try to remember to not mess with DLL file names in the future.

David

@JacobSmall gives more details on this in this thread:

1 Like