Issue with BIMOne Write to Google Sheet Node

Hello. First of all thank you for this fantastic package, it is a game changer in my opnion.
I’m making a script where I use read and write to google sheet that was working fine until yesterday. Today I’ve added a option to export different data and the write to sheet node is now returning a error:

I’ve made some changes on the spreadsheet too but being careful to use the exact same names on the sheets. The curious part is that the read from sheet node is working properly with the same info:


I use the read from sheet to identify the first cell with no data.
Already tried to close Dynamo, Revit and restarted the computer to clean an eventual glitch but it still doesn´t work.
Any ideas of what’s going wrong?
Thank you,

Hello Gustavo,

Could you please tell me which version of the package you are using? There was an update (1.1.0) 12 days ago and I want to figure out if this is a new bug or one that already existed.

Also, what version of Revit and which version of Dynamo?

Could you post some of the upstream nodes and their data as well?



Hi Vincent. I’m using Revit 2019 because it’s an old project and we can’t migrate right now.
BIMOneGoogleAPI 1.0.4
Here´s the .dyn file. I think you’ll not be able to test because of some escpecific shared parameters we use but at least you can see what I’m trying. It’s a WIP, don’t forget that!

D2.0 - ESQUADRIAS - exporta lista.dyn (97.5 KB)

The part of the graph that is connected to the Write to Google node is new demand that I’m testing. I was trying to export dome data from a Curtain Wall.

Thank you for your attention.

Hi again Vincent. i owe you an apologize for taking your time. It was a problem on the data I’m feeding into the node. I was trying to write a Level instead of a Level Name.
I think the error message made me think it was a problem with the node.
thank you for your attention.

1 Like