Index was out of range

Hello. I try to learn Dynamo to use in my thesis. When I tried to learn, I confronted of “index was out of range” problem. To solve I tried to install and uninstall Revit 2020 multiple times. However, it doesn’t work. I added print screens. I’m using Dynamo version. Can you help me?

You haven’t anything selected in any of the nodes that give an error, thus the node tries to look for something in while there is none to look in. This will mean that when the node tries to find the item at place 0 in the list that should be in the node there is nothing for it to find and thus the index it uses to try to find something is out of range.

Dynamo heavily relies on lists as input for nodes.
If you’re not very familiar with code, Lists are build with an index for every item.
Fof example:

List 1
[0] Item 1
[1] Item 2
[2] Item 3
[3] Item 4

The “[0]” is the first index of the list and “Item 1” is the first item in the list. Knowing that every item in a list must have an index you can get those items by specifying the index (this is what the List.GetItemAtIndex does).

If you try to get the item at index [4] in the example list you will get the error “Index is out of range” because there is no fifth item in this list.

I hope this helps and good luck learning Dynamo!

Thank you for a quick response. However, I asked to one of my friends who uses an old version of Revit. He got no warnings for a node without any connection. You can see in the photo. Also, the teacher which gives a lecture on udemy didn’t take any error.

Instal the latest version of Dynamo

From Revit 2020 and up Dynamo for Revit is controlled by Revir updates. For Revit 2017, 2018, and 2019 the most recent version is 2.0.3.

@gokhandYZYTE Look for Dynamo Install 2.0.3 here:

Then make sure you are using the correct version of the package which those nodes are from (I think Archi-lab but I can’t confirm).

Hi thanks for answer. I replaced attached file with the file which is under the revit(DynamoForRevit).

However, this time I cannot achieve the dynamo application under the manage bar in Revit.

Do you have any experience about it? Thank you.

Assuming you’re in Revit 2020.2, this may be of use: Dynamo panel missing from ribbon after updating to Revit 2020.2 or 2020.2.1

Hi Jacob. I tried to install revit 2020 hotfix. However it didn’t work. Also I solved with other way.

I wrote here steps of solution. Maybe some of users can be benefited from these steps.

Instead of revit 2020, I downgraded my revit version with revit 2019.

Afterwards, I installed dynamorevit 2.03 from

Afterwards, dynamo packages weren’t searched on the dynamo.

Therefore, I followed installation of revit hotfix 2.2 from one of website. I’m not sure but I think updates from autodesk doesn’t work.

Now it is working.

Thank you for answers and kind community.