"ImportInstance.ByGeometry" Error

It occurs under certain conditions, but I get an error in ImportInstance.ByGeometry.
The target of Import is Nurbs Curve.
I generate a NurbsCurve with the following three points, then extend its end point and import it, an error occurs.
This error does not occur if I change the coordinates of Point a little or don’t extend the end point.

What does this error mean? What’s wrong?

Point.ByCoordinates(0, 0),
Point.ByCoordinates(107318.863, 140970.512),
Point.ByCoordinates(170968.841, 225317.234)

Error message is
“Unable to compute edge from curve : IG_CURVE_BS3_COI_VERTS – Curve or its approximation have coincident control points”

Dynamo version is

Thank you.

Try to play with this option.


Options --> Scaling for geometry.

Plus, you can also bring the curve into Revit with the node “ModelCurve.ByCurve” rather that “ImportInstance.ByGeometry”. It makes it better for you to further process the produced curve.

Thank you for reply.

I had already set the Geometry Scaling to extra large.
Did this setting resolve the error in your environment?

I tried “ModelCurve.ByCurve”. Unfortunately, I got a different error.
”The multiplicities of other interior knots must be at most degree -2.
Parameter name: knots "

Thank you.

Yes it did resolve my problem but I am honestly not sure if that was the reason.

Regarding the model curve, your curve is actually a line as I noticed and when creating a nurbscurve from the line, it is being defined with degree of 3, therefore I would break the curve to points and then create a new nurbscurve from it with a degree 1 or 2. Then send the last to Revit using ModelCurve.ByCurve.

If all this doesn’t work, I would suggest to create the curve in an adaptive revit family. Use the node “ReferencePoints.ByPoints” and then create a line between these points either manually or with Dynamo using curve sth by reference points, I honestly don’t quite remember the name of this node and I’m out of office :(. Then add this family into Revit.

1 Like

Thank you again.

Well, it seems difficult for me to find the root cause.
The 3 Points and NurbsCurve I wrote in the first posted message are extracted to help you understand the phenomenon.
Actually, there are dozens of NurbesCurves that connect many of the calculated points, and this is one of them.
The other NurbesCurve didn’t get an error, only this one happened to get an error.
I also tried NurbesCurve made with points arranged in a straight line, but no error occurred.
If I knew from the beginning that a curve would be close to a straight line like this, I could do individual processing, but in actual geometry it could be a variety of curves.
I will investigate further workarounds and causes along with your advice.

Thank you very much.

I forgot to write.
If the shape of my geometry allows, I think it might be most effective to lower the dimensions of the Nurbs Curve.
Thank you for your advice.

1 Like

You’re welcome @at_yan. I unfortunately do not know the source of your problem but there is always some sort of workaround. It’s very helpful to sometimes keep task oriented and try to scope the type of input in your workflow. It can sometimes save you alot of complications.

This was very helpful for my problem. Thanks!

1 Like