Id(s) to Family types

Hi there,
I’m trying to import columns in a Revit Model via Dynamo. In order to do this I have created an Excel file which contains all the columns that I want. I have attributed to each column an ID number (which Revit will create the type of column that I want with).
I have only been able to create a single column using one ID (see picture). When I try to input a list of IDs, the “Id to Element” box Shows up empty and it doesn’t create any Column at all.
If someone could advise me, I would appreciate it a lot.
I’m new with Dynamo,

Dropbox link for Picture:

Sorry but I can’t upload Pictures since I’m a new user.
Could anyone tell me what should I do?
Thanks in advance

Please use DropBox or similar to send some screenshots

The ID is not a unique identifier and changes, even by just reopening your Revit file or undoing. Therefore its not reliable to identify elements, you instead would need the GUID. It may well be that your script is functioning correctly, but the Id’s you are providing from Excel no longer refer to the columns.

It might be worth updating the mark parameter of each column to create your own Id system as it will be more accessible.

1 Like

Thanks for the idea!
Dropbox link:


I’m Aware of this Problem. I’m taking the Problem step by step and for the moment I would like to Input all the columns. But Thanks for the advise. I’m going to check what do you mean with the mark Parameter.

It could be a data formating issue. You could use a Watch node and an Object Type node to verify the type of data coming out of your List.TakeItems node (you need integers). You could also test different lacings in your Id to Element node, but note that Element is singular here.
Bakery has a node called bv Elements to IDs but I didn’t test it yet.
Be aware however that, as @Thomas_Mahon mentioned, this method could be inappropriate…

Thans for your answer @Yna_Db ,
The data coming out of my list are “double”. I tried to round the Number by applying a box called " Math.Round" but the list is still showing up empty.
Well maybe the Singular “Element” it is a futur Problem. In the meanwhile no elements at all are getting in the box “Id to Element”.
@Thomas_Mahon is right, but the thing is that everytime my columns need to change, I need to reproduce the process. I’m not applying changes to my columns but creating new ones. I m not, for the moment, concerned of the real Id.

Please see here for the double to integer issue:

1 Like

The box “Math.Round” was not helping since it doesn’t change the Format. But with the second solution (Code Block with the int[]) doesn’t work either. The list is still showing up empty…

I’m sorry, the Problem was in fact solved with the Code Block (int[]). I was just using an unexisting Id…
My fault and thanks a lot !!