How to get Worksheet Names, Excel file

works fine from my end, what is the output of your “Get Worksheet Names”?


It would be helpful to know what the issue is, what errors you might be getting, what was your expected result, etc.

1 Like

It says run completed ,but no output. I am attaching the exceltrash.xlsx (602.9 KB)
xlsx file…

No issues…

You could try and extract the content of the custom node and see if there is any error messages in there when it runs, also please enable the previews (using the little pin) when uploading pictures.

1 Like

Thank you.Your output is what i wanted. I reinstalled only yesterday for the view type problem which still persists(i resolved it using elements)…
I will try again or resinstall dynamo again.

Remember that this node is a part of “Archi-Lab Bumblebee” :slight_smile:

Also I would suggest that you try extracting the content of the node as the error might be caused by the fact that you’re running Dynamo 2.0 and I’m on 1.3.x

I am totally at sea with dynamo and revit…Just wandering in the forest.
How do I extract the content of the node?.

Double click it and copy/paste the content to the main graphing area (white background).

If you’re just starting Dynamo I would really recommend you to start by reading and performing the exercises in the Dynamo Primer:

I did that before even i wrote the first dynamo picture.I had a old version of dynamo which i updated twice to reach 2.01.I was scarred to reinstall the packages.But I will do that now.

But you do not show any of the relevant outputs making it very difficult to help you…

1 Like

I have been posting the full scripts and the dyn files.Do i post the input files also?.(without expecting howlers!).For your curisity I wast playing around to get the view schedules in revit into a single excel file(which i have managed by now).
later i am planning to do geometry.
right now i am trying to get copy/paste as you posted.

Try and read the full post linked in reply number 3…

You are not enabling the previews in your posts:

You are not showing what you’ve tried e.g.

You have not written your version of:
Revit, Dynamo, Excel, Packages used

Generally a LOT of information is missing in your original post…

Where have you posted your dyn file? Not in this post…

1 Like

In this episode i presumed ,that since only 5 nodes were invloved the jpg was enough.I will be more careful as learn the ropes of forums.

Can you help me more with extracting the content of the python script.?. How do I do that?.I tried double clicking but all i got is some dyf file,and lost the dyn ?.
I just want to see the getworksheetnames code…Is the problem because of a 2007 excel ?.
I have downloaded the primer for version 2 …

That will likely be a problem in the future if it isn’t already. Asking current software to work with 11 year old software will usually cause issues.

1 Like

Look at the gif it show exactly what you’re asking for…

To Jacobs point, that is exactly why I asked you for your version numbers for dynamo, revit and excel… We cannot help you if you do not deliver relevant information…

Err.!.. How did you get that python script code…?

Got it …Thanks.

That could be precisely the issue. Bumblebee was not working on Dynamo 2.0 until recently. Please get the latest version from Package Manager.

1 Like