How to delete DWG links from Revit 2015

I have been trying to find and delete imported dwg’s from my model. I have tried what is talked about in this thread but from what I can gather the ‘bimorph.reportCAD’ is not available for dynamo 1.2.1 for Revit 15.

Does anyone know any other way to do this for Revit 2015.


It should be compatible with Revit 2015 and Dynamo v1.2.1 as its built on Dynamo 1.0. What issues are you experiencing?

Hi Thomas,

I have installed 1.2.1 bimorph and it does not contain the ‘bimorph.reportCADlinks’ node.
Will a later version of the bimorph package be compatible with 1.2.1?

Bimorph version 2.0.2 works with 1.2.1 and has the desired node. Try that version and see if there are any issues.

Hi Jacob,
Thank you for the suggestion, that worked. I mistakenly thought anything above 1.2.1 would not work. However the script doesnt seem to be working now. I have cad imports in the file but the script says null.

@joewallace83 Your missing file.path input.

@Kulkul Thank you for your reply. Unfortunately that has not helped. I have just imported new cad files and saved and re run the script with the file path connected but no luck

Can you share a .rvt for someone to help you troubleshoot with?

The filePath input is optional and only needed if you want to report external RVT or RFA files (‘external’ being any file other than the one you have open with Dynamo). It will automatically report your active file without any inputs.

Can you download the latest version of BimorphNodes (v2.0.8) and see if you still have the problem? If you do, then double-click the medium-grey area of the node to open its Custom Node environment, then copy the Python node you see and paste it back into your Home workspace. Wire up your inputs and then click run as this will show errors (unfortunately custom nodes don’t provide warnings).

The node is designed to report the following if no links or imports are found:


1 Like

I created a new file and imported one cad file and ran the script and again it showed nothing.

I am using bimorph 2.0.5 as it is the latest that will run with dynamo 1.2.1

This is the script and dummy file I have tired using which doesnt work

bimorphNodes.ReportCADLinks.dyn (6.3 KB)
dynamo cad links.rvt (1.4 MB)

@joewallace83 its a bug, and an odd one too. There is an error which occurs in line 32 of the python script. This line simply extracts the name of the link or import using the Parameter property. This property has an overloaded input which can either take a builtin parameter, a string or a definition. I always use builtin parameters. Now, for reasons unknown, IronPython is interpreting the Parameter property with only a single input type - a string. Hence, inputting a builtin parameter throws an exception. This is not normal and is either a bug with Dynamo or a bug with the implementation of IronPython in Dynamo, rather than a bug with the node.

FIX: I’ve changed to a method which does work with builtin parameters. I’ve updated the package: BimorphNodes v2.0.9 available on the package manager. Please download and see if that solves the problem.

Also, BimorphNodes v 2.0.8 (and now 2.0.9) is compatible with Revit 2015 and Dynamo 1.2.1. If you get errors when placing bimorph nodes, like “…this node was created in a newer version of Dynmao…and may not work” etc click to continue opening and it will still work.

1 Like

Hi Thomas, I’ll be honest I did not understand much of that first paragraph but I downloaded the most recent package and now it is working perfectly. Really appreciate you looking into this.