How to array families on curves

Hey Guys,

Peace to all who are reading this Topic…:grinning:

I want array family file like this…

So I made graph like this

But result is…

  1. Dynamo does not allow families to be spaced below 250…

the Korean error message says, “The value is too large or too small to fit the format Int16.”…

But since the length of the family is 250, I have to arrange it at 250 intervals

  1. All families have to be rotated to the curve, and now the families are rotated at the same angle.


  2. I want these families to be arranged naturally along the curve…
    Also, sometimes need to control the family so that it is not arranged in any interval…

How can I do this…?

주행공동구뚜껑.rfa (308 KB)
Home.dyn (57.0 KB)
Civil Report.xlsx (798.8 KB)

what is the curve length which you are trying to divide by 250?

Total length of curve is 8,000,000mm… about 8km.
So long… and family length is 250mm

Is it related to length?

is this an out of the box node? My guess is that it’s using the parameter of the curve from 0 to 1 - there might not be enough precision to divide that nicely into 32,000 parts in between 0 and 1 with only 15 digits that floating point numbers support. I would try slicing the curve up into 10 parts or so.

Thanks : Michael_Kirschner2,
I Think “DividecurveByDistance(LunchBox)” has problems with this.
So I tried to use AdaptiveComponenet.ByPoints …

I want to place the families on a 3D curve and the families to be placed in the vertical direction of each tangent.

This is related to old topics,

but I can not see the image because it is too small.
How do I align rotated families onto a 3D curve?

make your family based on some extra points (not a single point) and then use the normal or tangent of the curve at that point as a second alignment control for your adaptive component.

Thank you Michael,
I Tried it in two ways.

First, I tried to use “FamilyInstance.Bypoints”
this is working…
However, it does not rotate in the direction perpendicular to the tangent of the curve.
I do not plan to build a staircase…

After your advice, tried it the second way.

“adaptive component”

but the result is…

maybe something’s wrong…
What’s wrong with it…

With another value in Settings -> Geometry Working Range?

Thanks, franciscopossetto
Geometry Working Range is largest…

This is result of “adaptive component”

I can’t understand how “adaptive component” working…
Home5 adap.dyn (51.1 KB)