How set parameter yes/no for nest family

dynamo

#1

Hi everyone
I’m trying to change parameter in nest family but it failed only report Warning: “Element.SetParameterByName operation failed.
The parameter is read-only.”
This really helps with many solutions in the job, very nails get help


#2

Maybe you ned to check the “Shared” parameter in your nested family. If this parameter isn’t checked, you can’t change the parameter of a nested family.


#3

Thanhks @jbo for reply soon
I checked the shared and loaded into the project but still could not set value for it!
Is there any other reason?


#4

Is this the parameter in your nested family? To be sure, just change it in all nested families of your main family.


#5

Yes! But now I want to assign the display variable to a floor strut, if the strut does not touch the floor I want to hide it, if the parent variable is changed in the project then all struts is hidden


#7

Why aren’t you assigning your display parameters from your nested family to your main family? Then you shouldn’t have a read-only parameters.


#8

Maybe I should separate my family to handle every single family so independent seems to be the better direction!


#9

You are giving the parameter a true/false value but I don’t think it can read it like that way.
Maybe you should give it a string like “true” or “false”.


#10

True false values are usually 0 or 1.


#11

I tried all 3 methods - as boolean node, as string and as 0 / 1. Boolean and 0/1 works, the string doesn’t work. But just in my sample. I don’t think there would be a read-only error if there is a problem with the data type.


#12

Thank @JacobSmall @CVest reply!
I already checked and like result @jbo! The main reason is that the parameter nest family is not changed


#13

Did you find a solution?

If not, can you share the .rvt and .dyn file? I would like to try something :slight_smile:


#14

@CVest i have not found yet
This is .rvt .dyn! Please check help!
Formwork for column.dyn (35.4 KB)


#15

You can’t control a formula which is alredy assigned to another formula. This is the problem. If you delete the connection between the visibility and the “hidde show” parameter it should work.


#16

Thanks @jbo for help
I already delete the connection between the visibility and the “hidde show” parameter but it will not do result
Can you show me your result!


#17

Change the “Visible” parameter to False and not “hidde show”. If the “Visibile” parameter is already greyed out in the family editor, then you have to remove the parameter, which is assigned to this Visibility parameter. In the picture I’ve posted, there is as you can see the parameter greyed out, so you need to delete the association.


#18

sorry @jbo you actually did the way you say but maybe it’s still wrong somewhere! Can you send me the .rvt .dyn file that you have edited the way you did? sincerely thanks


#19

Sorry, but it seems as my instructions doesn’t work. I have to investigate further.


#20

Ok thanks @jbo


#21

I tried it out and it seems to work. Both with the Visibility-Parameter being linked to the “hidde show” Parameter as well as it not being linked to it. Try my graph out. Hope it helps.

12