Help with Sheet.ByNameNumberTitleBlockAndViews error


I’ve created a script that allows to select the levels, view templates and scope boxes and automatically create floor plan views and rename them to “Prefix Level Name Suffix”.

The next feature I want to add is placing these views in sheets. And so far it creates the sheets with the right Number and Name but always fails to place views on sheets. The view once applied the scope box fits into the sheet (if that makes a difference).

The error is something like:
Warning: Sheet.ByNameNumberTitleBlockAndViews operation failed.
View 0 could not be packed on the Sheet. The sheet is 2.75590551181102 x 1.9488188976378 and the view to be added is 12.0110831192295 x 8.95991527766546

What’s wrong?


1 Like

Views (their boundaries) are too large to fit in Title Block. Try resizing them down, using View Crop, selecting different Title Block also may help.

The view is small enough to fit. Even I tried reducing the scope box a lot but still doesn’t work.

I’ll try to load a different titleblock.

Definitely the view is small enough to fit but still the same error (placed the view manually):

1 Like

It seems it doesn’t like to do everything in the same workflow, even if I feed the create sheet node with views that already have been cropped in size or with small scale to fit.

I’ve been testing the node alone and seems to be very temperamental.

Please can anybody try the workflow?

TEST Views-By Level Creation and Place on Sheets WIP.dyn (22.3 KB)

It needs inputting the Titleblock family type, the view template and the scope box.

Hey there,

I faced the same issue. Here’s how I dealt with it :

Instead of doing everything at once I start creating an empty sheet and then I place the views. This way you can place the view no matter its size.

The nodes I used are Tool.CreatEmptySheet and Tool.PlaceViewsOnExistingSheets, both from the SteamNodes package.

Hope that will help

1 Like

Thanks for the tip!

However I get exactly the same result. Got Null from Tool.PlaceViewsOnExistingSheets (although the node doesn’t turn yellow).



That’s where I struggled quite a lot. You have to find the right list combinations and the right lacing. Don’t hesitate to play on the list levels.

It tooks me several tests to get it right.

I’m narrowing it to just one view (not even having lists), changed the lacing of Tool.PlaceViewsOnExistingSheets and still doesn’t work.

Doesn’t make sense…

Managed to get it working using the python script by @4bimfercesp from this post

However the view is totally off-center :stuck_out_tongue:

I got the same behaviour. It comes when you try to generate views in the same workflow of placing them in a sheet.
I think this is a faulty behaviour of Dynamo. The views keep the original size when they were created no matter you try to apply later a scope box. No matter if you try to apply a passtrough before Sheet.ByNameNumberTitleBlockAndViews is going to pick up the views from the “original existence” with the corresponding size. In fact, if you create views from different ways you realise it only catches the “first view” was created.

I tried to use SetCropRegion of Rhythm and it did not work. In fact it even gave problems to generate the views.

I managed to get they to be inserted in the sheet with the tool Create Viewport of Rhythm but with the problem of viewport title line fit with the original size of the view. Even it is clearly smaller because the scope box you applied.

Obviously if you insert that created view in Revit you are not going to have that wrong behaviour.

It is frustrating how badly Dynamo works.

As I commented on your other post, you need to manage the Transactions to make this work effectively and as intended in Dynamo.

yep, you need to use the transaction.end node to make sure the revit document is regenerated before trying operate on those new or modified objects. This would be the same as if you were using the Revit API directly.

Dynamo tries to pack everything into one transaction to save time interacting with Revit - sometimes that’s not what you want and you need to take control using the transaction nodes.


Yes. That worked.
It resolved not only the creation of sheet but other future process which were not working properly.

Thank you very much.


Hello - I’m having similar issues to this thread and I tried adding transaction nodes as you stated. Unfortunately it didn’t solve my issue.

The odd thing about the error (with the plan being too large) is that half of my plans ARE being placed on the sheet and half are not. If there was an issue with the overall plan size you’d think no plans could be placed.

Has anyone else resolved issues with this node? I’ve used it in the past and had success but this particular model just refuses to work.

Hi. I know it is old but I assume someone will have the same problem, unless Dynamo team have resolved the issue in future versions. The unique way I have found to resolve the issue with the views are bigger than the titleblock is adding a huge Titleblock type. I use 15000x15000mm so you get rid of this issue. Later, I change this type by the right one. This happen because the node takes the views before they are reduced by a template. No matter if you use transaction.