Help - Assembly Type Name to Assembly Members parameter

revit
dynamo

#1

Hi everybody

I’m a bit stuck with my little tool here and can’t figur out, whats wrong.

I’m trying to Transfer the Assembly Type Name to all Assembly Members Comments parameter.

First I collect the Assembly type name with Rhythm’s node GetParameterByName(TypeOrInstance) and then all the Assembly Members with Clockwork’s node Assembly.Members. Then setting the parameter value with Rhythm’s node SetParameterByName(TypeOrInstance) and then it only sets the parameter value on one element.

What am I missing?

Thanks in advance!

MM


#2

Your connector from SetParameter for Elements, by the looks of it you use it from the Flatten, try using the one from Assembly Members instead.

Then it should collect all elements instead of only top one.

If it doesnt work let me know and i will make you an example.


#3

Try to set the lacing of the Element.SetParameterByNameTypeOrInstance node to longest


#4

Thanks so mutch for the fast replies.

It works perfectly now.

By setting the lacing to longest did the trick! :smile:


#5

You dont have to do the lacing and you done the Cross Product and not the Longest.

Here is my example.


#6

He’s not using the same version of the Rhythm node, that could be the reason why


#7

Didnt thought about that, makes sense :slight_smile:


#8

It’s working, with both longest and cross product.

Now I’ll will try creating it, with categories and all element of category.

Thanks again :slight_smile:


#9

@mbm2PCT9 mark the post as solved.


#10

Assembly Members is return ‘null’, yet contains 2 generic models a wall and a void. Any thoughts why?


#11

hmm it should work! :thinking:
Have you tried to open the dyf (Assembly.Members) and take a look under the hood?

I remember I got some trouble as well and I think it was the ReturnListOrSingleValue node because my packages was deprecated or something.


#12

I have exactly the same error. Any ideas how to fix it? Thanks.

I also have another Clockwork node reporting Nulls when it shouldn’t - the Element.Level node…
@Andreas_Dieckmann


#13

Solved it! I needed to install the latest version of Iron Python and reinstall Dynamo. Not only is everything working but Dynamo is running it’s graphs much faster than before.


#14

This is a great code thanks! I do have a question tho, it only works for one assembly at a time? I have over 100 assemblies so this is still does not seem like the perfect solution for me.
Im trying to get all assembly members for all my assemblies, so i can give them a type mark named like the assembly name (where the elements are in). Someone who can help me out?


#15

Hi Noes
If you want to apply the assembly name to all assembly members Type Mark parameter, just apply Categories and all element of categories to the Element.Name node.
I will share my solution with an image.

I hope it helps. :slight_smile:


#16

Hey! Ah great, thanks for sharing!

Turned out I was working with an older version of Dynamo, now it works perfectly!


#17

You welcome Noes :slight_smile: