Graphic Card for Dynamo

Hi All,

I’m experiencing some troubles working with large scripts, and my best guess is the lack of the VRAM memory. So, two questions:

  • Could be that I have an old graphic card Dynamo gets slower as the amount of nodes of my script grows?

  • Which graphic card do you recommend? My actual hardware is as follows:

Thanks in advance!

Graphic drivers up to date?

Hope you have a 4K screen, too.

Yes, drivers are up to date. 4K screen is completely out of my budget :frowning:

I discarded the amount of RAM (8 GB) because in my laptop I have a slightly better graphic card but 16GB RAM and have the same problem.

Is my guess correct? Do I need to upgrade the graphic components?

Hi @Jorge_Villarroel

Before i suggest any specs my work in BIM gave me luxury of testing machine specs, graphics card, machine specs the whole lot.

Your specs is not even close. Sorry…

You need at least 32gb ram, 2gb ram for graphics card and an i7.

If you want to save money. Just 32gb ram will do. Your graphics card ram of 1gb and i5 pc is good enough. In addition avoid using laptop if possible they have no power and will not match to a desktop performance can do.

This will save you checking around…

1 Like

Are the scripts graphics heavy? That is are you generating form in a meaningful way not rebuilding existing geometry? Turn geometry preview off on any nodes which don’t require you see the geometric output. I.E.: rebuilding room volumes has value, butno need to preview a second time when you group them.

Yes, @JacobSmall, I was careful to turn off the geometry preview in almos all of my nodes. Also, I deleted watch nodes and the “watch” display from nodes.

I have a $300 2-year-old I3 laptop with Intel graphics and 6Gb RAM, feeding a $250 4K TV, and it is great with Dynamo.

Have you tried your graph on different computers with similar results?

I’m actually making some test now. When I’ll have some results I’ll post what I found.

You also testing 32gb ram on desktop by any chance?

Not. I’m testing it on a Hi-end laptop that my company bought fo the BIM team. I’ll post the specs coming soon…

:+1:

I have the same issue.

On large graphs, it becomes difficult to pan and zoom around the graph. No previews enabled, manually run – just slow and jerky like it’s catching up to my movements. I never thought about the graphics card being the issue. I have decent cards in my desktop and my laptop, however, so I’d be a little surprised its the card.

My guess is the graphs are way larger than Dynamo was designed for.

2 Likes

Having seen some of your graphs, yes.
:stuck_out_tongue:

Still really good work.

I’m having the exac problem. Maybe my graphs are too big, but I don’t think that I could make it smaller. :frowning:

Code blocks and Python script are your friends. :slight_smile:

1 Like

@Jorge_Villarroel

Here is a more detailed explanation. Not sure though if srill true on the current version of dynamo, but if it is the explanation was spot on.

http://dynamobim.com/forums/topic/node-to-code-vs-custom-node-speed/

1 Like

still looking for help on that, btw :wink:

1 Like

You’re not forgotten.

:slight_smile:

1 Like