Geometric references in Dimension.byElements node

Hey guys,

Im trying to make a script to dimension self-made families. Every time I run the Dimension.byElements I get the warning:

The references are not geometric references.
Parameter name: references

Do any of you guys know how to create these geometric references in families ? In the image u can see all my inputs into the node.

1 Like

Hi @verdi,

It’s possible with custom nodes.
You can use FamilyInstance Reference and Dimension ByReference nodes in Genius Loci package.

4 Likes

@Alban_de_Chasteigner Thanx a lot for the advice. I did not know the package. ive tried it but doesn’t work for some reason. Would you know why ?

It’s hard to help you without seeing all the graph and knowing what you want to dimension.

Example 1

Example 2


7 Likes

Thank you! You’ve cleared up the way it works a lot. Work perfectly !

Hi @Alban_de_Chasteigner,
When I saw your response, I got excited about this package from Genius Loci and had some success with automating dimensions in one view to one line. Is it possible to do multiple views and multiple lines?
I can’t seem to lace them through in a way that allows me to. Do you know if it can be done or does the python script not support it? Not very good with python yet.
I am using the same node, Dimension ByReferences shown above.

Hi Daniel,

Here is a quick example to dimension an element in multiple views :

What you’re trying to achieve is probably possible with proper list levels and lacing.

Thanks @Alban_de_Chasteigner,
By switching things up, I managed to kick out a list of dimensions that was equal to the lists that I was inserting. Now I am just trying to trouble shoot why Revit is actively deleting all but the first of the dimensions upon creation. It makes me wonder if python is trying to use the first line on the list for every view to dimension to. But I am guessing that it is in fact possible to dimension to different lines. I just need to lace it right. Maybe you confirm if this is possible as well? I wonder if I can find a node that can break down the location of a dimension that dynamo places.

You’ll find there are actually a number of “Dimension.___” Nodes that can help you trouble shoot what is going on in your file:


If Revit is automatically deleting dimensions, it is usually because something wasn’t parallel.
If you look at the Dimension.Value output, you may recognize the -1 values from the revit id error report. It may help if you remove the dimensionType input while checking for errors; just one less variable.

If even one dimension isn’t parallel, the entire list probably will not populate in revit.
Thankfully, the GeniusLoci Package outputs the sketchplanes from the elements that you reference:

Just make sure to filter out the references that are not parallel before sending them into any dimension node.

Thanks again to @Alban_de_Chasteigner for his work here. It is a lifesaver!

1 Like