Generic Annotation FamilyType to create legend - NOT CREATING :(

Hi , I would like to create a Legend with the Electrical Symbols used in the model.
I created the graph with two types of nodes. However neither of the two actually create any object on the Legend view. (Note : The Generic Annotation Family are nested in the Electrical Fixtures Family)

1 Like

Try with this " FamilyInstance.ByHostAndPoint "

Family

Hi @iconicdesignent,

To place family types on a legend use the Create Legend Component node.



Create legend component.dyn (12.2 KB)

P.S : As the Revit API does not integrate methods for legend components, the workaround is to insert a single component in the legend, duplicate it and change its type, which the custom node does.

2 Likes


I dont understand why its showing null. Is it because it is a nested Generic annotation in Electrical Fixtures Family?

Hi , I tried the Legend Component and even used the graph you so kindly sent. but i am still getting a null result. :frowning: I dont understand the problem.

Did you place a first component in the legend view ?

Try with the Electrical Fixtures and not the Generic Annotations Category.

1 Like

Hi Alban, Thanks. Finally got it to work. I did add a first component. But i think the views wasn’t working out right. I changed the Legend View and it works perfectly. You are a star!!.

Hi Alban,

I got the Icons to show , is it possible to adjust the visibility parameter set in the generic annotation to turn off, because this is currently what i am getting.

I don’t think.

The legend component is really limited. You can’t access to its parameters and even tag it.
The only thing you can do is override its projection lines.

ok, thanks. Also i would like to add the description text of each component next to it. I am using the Getparameter node and for placing the text , the springs Textnote.bypoint

Is there a better way that you may be aware of? Thanks in advance.

Hi Alban,

Please see the same graph with the text placements supposed to be aligned to create a legend. But its being shifted in the Legend View. Attaching the Dyn file. [Create legend component with Text Description.dyn|attachment](upload://oKJtbdn3awDIc

1AeCbXejtGuMWw.dyn) (35.4 KB)Create legend component with Text Description.dyn (35.4 KB)

Hi Alban,

Sorry if it feels like a silly question, I do understand the concept you stated, however the nodes with the same points are still not giving me the result you have shown. Kindly c the result i get in the image below. I don’t know what is wrong and how to fix it.
Should i be using the same location placement point for both legend and text? or should the locations be different?

Hi,

EDIT : The node has been updated and now includes an additional translation to place the components at the expected location.



Create legend component with Text Description.dyn (21.3 KB)

1 Like

Thanks So much. I will give it a go.