Generative Design BUG?

Hi All, i’ve encountert this weird problem with generative design not getting the right data pushed through from the script it seems. What i have is a script that works in Dynamo but doesn’t show any geometry preview in Generative Design for Dynamo Revit. Trying to find the underlaying reason i found that the data in dynamo doesnt align with the data as shown in Generative Design. For example. i have two lists that both count 6 items. In Generative Design the data transported shows that one list has 6 items as well but the other one has just 1 item instead of 6. Does anyone know how to solve this?

Are you sure the input data set matches? I can’t really see enough to know where the issue is.

Hello Jacob, the input dataset matches. I just tried the script out on a different computer and i found no problems there with the same script. These are the files i´ve been using:

GenerativeDesign_debug.rvt (5.3 MB)
GenerativeDesign_debug_001.dyn (765.9 KB)

I’ll try to take a look later today. What version of GD are you using?

The version i used earlier was I also tried the new version of Revit 2023 ( where i had the same problem.

Are you using the latest version of Generative Design in Revit 2022?

If you are, you should try to use the include dependencies option as there are some custom Definitions not getting copied over. This means, when generative design is running it does not have access to those custom packages and definitions. Which explains why you see a disconnect in Dynamo versus Generative Design.