Generative Design 2021 - Geometry not visible and Outputs blank in Explore Outcomes

I’m using a Dynamo graph that was originally created using the following Software and packages:

  • Revit 2020.2.1
  • Dynamo 2.3.0
  • Dynamo Packages:
  • spring nodes v.203.1.0
  • Refinery v.0.60.0
  • BumbleBee v.2019.2.0

The Outcomes can still be visualized successfully in Generative Design using Revit 2020.

I’m trying to run the study now using the following:

  • Revit 2021.0.0.383
  • Dynamo 2.5.0 (Got the hotfix GenerativeDesignRevitInstaller-v21.5.10)
  • Dynamo Packages:
  • spring nodes v.203.1.0
  • BumbleBee v.2019.2.0

The graph runs successfully in Dynamo, but some of the geometry will not display in Generative Design. Outputs are also blank. Please see the image attached showing the results in

Revit 2021.

What I’ve tried:

  • Ran all the study types: Optimize, Randomize and Cross Product (using 3 values for each variables).
  • Copied any custom packages to the definitions folder.

Any suggestions would be appreciated!


Likely one of the following:

  1. A node in between your remember node and your evaluation calls the Revit API - this is often the case with Python nodes.
  2. You are trying to minimize the outcome, and there is a condition (say an offset value of one light year) where the evaluation will be null, which counts as 0. Once the genetic algorithm finds that optimal outcome of 0 it’ll keep exploring other solutions in that range showing you perfection which is actually a failure.

To know which we would need your graph; the solution also likely requires some degree of editing.

Thanks for your response.

Please see the graph attached and let me know if you have any suggestions!

PassionProject_BldgGen_R21.dyn (229 KB)

I would need the associated excel file as well, but my guess is it’s an issue with bumblebee reading the data on each run, which would explain where you’re falling apart. Basically you’re trying ot launch 6 instances of excel concurrently, read the data in then close it…

Try putting a remember node after that, and disconnect the input to the excel read node.

Thanks for your response!

Here is the Excel File. I tried adding the Remember node after the Read Excel node, but no luck.

Side note, when I was working on this graph in Revit 2020, I was having the exact same issue. It was caused by the spring nodes (Curve.Offset and LineLoop.Merge). I resolved it by saving the .dyf files in this location: C:\Users<username>\AppData\Roaming\Dynamo\Dynamo Revit\2.3\definitions

I’ve done that in Dynamo 2.5 folder, but no luck.

Let me know if you have any more suggestions!

Thanks again!

Occupancy Types Key Values.xlsx (127 KB)