Gather All Elements of Category View gives a Null but passes data?

Trying to get all floor plans and I keep getting a weird null value?

Do you have 3d view templates in your file?


the Project Browser maybe, in the list that is?

not sure what you are asking?

the Project browser is a view as i’m told :slight_smile:
btw, there are some good nodes that give you view types by type

what would be a way to gather views then without the badness?

tried those and they were giving nulls as well. I am going to remove the OOB ones and try one of those instead
Modelical - Get Views By Type - FAILED
Archi-lab_Grimshaw - View.GetByType - FAILED

there must be conflicting nodes in here…ugh. I’m trying to isolate different threads of the script to see because when I freeze some of it it will work.

Have you tried using OOTB ElementType node?

yes I have tried those. something down the line is causing a conflict. it may not be the collector that is the problem.

Try using python:

import clr
from Autodesk.Revit.DB import*
from RevitServices.Persistence import DocumentManager
import Revit

doc = DocumentManager.Instance.CurrentDBDocument
col = []

views = FilteredElementCollector(doc).OfClass(ViewFamilyType).ToElements()

col = views.ToDSType(True)

OUT = col

hmm. the culprit is Element.Delete from Archi-lab Grimshaw. if I freeze it all is good…

ok so the issue is the delete elements…ive tried a couple different ones with the same effect. I even have a passthrough…I gather all my unused elements and want to delete them at the end.

any suggestions?

ive tried transaction nodes to no avail…

For system families the rule is that you cannot delete all items, at least on item must remain in the families, or at least one Level must remain in the model

I am doing an updater that will change sheet and view names and once done delete empty views and sheets.