Floor default thickness

I would need to get the Deafault Thickness of the floor type but somehow I get strange numbers as result which divided by “3.28083…” gives the “correct” result. (Tried it with multiple floor types)

I can’t use the “get parameter by name” because I need to switch between german and english versions. How can I get the correct value for this parameter?

Also I tried another python script which I modified from getting a walls thickness. I would need a parameter which I will highlight on the picture but I can’t find it. I don’t even know if it could work like this also with floors. I’ve looked for it on revitapidocs.com but I haven’t found anything.

I think below image helpful for you.

You are basically doing what the OP is already doing :slightly_smiling_face:.

It’s because the returned result will come in internal units, when obtaining numerical values via the API.

You can either convert the value as you are doing now, or you can use the UnitUtils class from the API to work around this :slightly_smiling_face:


That is one way to work around :smiley: Thank You!

Thank You for the fast reply. I’ve got it.
Here is the code if someone else needs it.


it’s easy :smiley::smiley:

Just make sure you mark your solution as “solution” so that others with this problem can find it easily!