Filter Vertical Pipe and select them

i followed this topic to filter my vertical pipe.
this tutorial is great
i’ve attached the dyn file
Sort Pipes by Slopes and Direction.dyn (101.6 KB)

in my case i just want to filter the vertical pipe with sloped parameter to be “Not Computed”.

there is in dynamo to actually select all vertical pipe that it filter by the script that i’ve attached here? because according to the tutorial it’s just override graphic in the specific view that open in revit but i wanna to select them all from dynamo.

The basic process should look like this:

  1. Get all pipe elements from All Elements of Category.
  2. Get Slope parameter value.
  3. Check if value is Not Computed. (I believe this shows as a blank string "" in Dynamo.)
  4. Filter elements based on value using FilterByBoolMask.

EDIT: Now that your nodes are visible, it looks like you already have these exact steps in your graph. If that’s all you need then you can remove the rest of the nodes. If there’s something more you’re after you’ll have to be more specific on what the issue is and what you’re expecting.

I want them to be selected in view and than I’ll isolate them.
example:


as you can see there is 4 pipe selected in view

my main goal:

  1. find the vertical pipe and then number them - it will be easier to filter by minimum length
  2. there is some vertical pipe but their slope parameter is something like 23489432.213% - so i want to find them and fix them to be “Not Computed”

Hi,

The custom node from the Genius Loci package Group Lines by Orthogonality can probably help you to identify the vertical and sloped pipes.

you’re right.

now how can I select them in revit?

Just click on the green ID (green number) in the watch node.
It will search for the element in Revit.

when i click on the green number it’s just show me the element - not select it. and i want to select them all at once.

The Springs nodes package has the SelectInRevit custom node for this.

it’s worked! thanks a lot! :clap: :clap:

i run the script in one of my model and it selected not only the vertical pipe

it’s select the pipe that looks vertical but their slope it’s something like this XXXXXX.XXX%
i thought it should select only the “Not Computed” pipes.

Hello @ROSIE_SG …ok if your risers slope, you can try something…and try to sort by vector…but best they dont slope :wink:

1 Like