Export 3D view from a List to NWC

Hi All,

FOR SHARING…

After collecting information regarding NWC export from the number of topics I decided to Share the code I made.

After reading queries from this 2 topics


Here is what I have (an alternative version)

Graph image

Python Image

The graph (dyn)

4BimFerCEsp_Nwc3DMultiViewExport.dyn (7.1 KB)

And additional Navisworks Properties you might want to add on the Python code amongst them are highlighted

Any issues let me know
Hope you find this useful and thanks to the Community
Please try to share as much as possible…

NEW VERSION of DYN below…

2 Likes

Thank you sir!

@4bimfercesp The script only runs sometimes… Like ill run it once and it will work and then i try to run it again and the output says “success” but the NWC’s arent made in the folder

Hi sorry…I am looking at the code I forgot to place a run me bool.
I am not on a pc at the moment but for now you can unwire IN[1] run the graph it will turn yellow coz there’s an error Wire IN[1] again and it will work.
Apologies. can you let me know if that temporary sort it.

@4bimfercesp I tried that and it goes yellow and doesn’t export.

New version of the DYN graph

4BimFerCEsp_Nwc3DMultiViewExport_v1.dyn (7.8 KB)

can you try and let me know.

1 Like

see new version

It still didn’t work.

its says you don’t have the folder C:\TEST? Please create the folder or put your own folder path
Also make sure when you running the graph your active view is a Sheet or a 3D view.
The graph was tested many time over so it will work.

1 Like

Thank you 4bimfercesp for DYN graph. Great script :+1: . I have added little modification to graph . Hope this could further simplify graph.

1 Like

Thanks you for Sharing
I use dyn file
when I run software , I do not find out of file output (Naviswork file)
Please help me

@4bimfercesp Great Script , Thanks for sharing , I’ve been searching for something like that for a long time.
@manish689246, I used your part for the file path and added another part to search for a keyword in all the views and export all views that contain this keyword.

4BimFerCEsp_Nwc3DMultiViewExport_v2.dyn (30.1 KB)

image|690x237

1 Like

This is a very useful script. my issue is that i need to open the Revit file from BIM360. can anyone advise how to do that? thank you in advance

Dear 4bimfercesp,

I am very glad, that I’ve found your Dynamo node “Any 3D view from a list to NWC” with Python/DesignScript in it.

But I think, there’s an issue or error, so it doesn’t work proper in my opinion.

The behaviour of the node which I could observe and repeat:

“START”
First run: The script starts, NWC files are exportet, everything fine
Second try: The script starts, reports ‘success’ after nearly zero time, but nothing has happened.

Workaround: I disconnect IN[0] or IN[1] of the NWC-Export-node, start a run of the script to provoke a error, then re-connect all inputs of the NWC-Export-node. After that I’m able to start a new run which runs fine and creates NWC files. Once.
And so the circle closes from here on you can jump back to “START” again.

Maybe you feel like to revise your node and tilt this behaviour? Where would it come from?
Maybe you could explain a little bit about your node to the community.

e.g. the Input “IN[2]” … is it a YES/NO choice whether to run the node or not?

Thank you very much in advance, if you’re willing to reply to your very old post.

Michael

Here is my version. The Python-Node “Any 3D view from a list to NWC” is copied from the file “4BimFerCEsp_Nwc3DMultiViewExport_v1.dyn”

(Nodes grouped with color green are defined Inputs for the Dynamo-Player).

I think you will have to publish first and then cache the file in your local drive so you could point the location to the cached file.

thank you for your reply - does that mean that cashing the file is done “manually”? can it be done through dynamo?