Excel - Operation failed


I have been struggling to fix an error with the Excel and CSV Import and Export nodes. When using them, I receive the following error.

I have search the forum and reinstalled Excel, upgraded Excel, Reinstalled Dynamo, and Reinstalled Revit, with no improvement

I am currently running:

Revit 2017.2
Dynamo 1.3.2
Excel 2013 (32bit)

Note I have installed Excel 2016 and this didnt help. I have also deleted the 1.8 file in the registry.

Any ideas would be greatly appreciated!

I do recall someone on the forum stating that the 64 bit version of excel was required.

1 Like

Hi @Michael_Kirschner2

Was it this topic?

1 Like

Curious to see the csv export issue though… that shouldn’t be impacted by a 32 bit excel install, right?

The FilePath node gives me a file including extension, i don’t see that in your graph.

btw. i think Excel 64-bit is only needed when using RevitDBLink

1 Like

Thank you everyone, however @Marcel_Rijsmus may be right, 64bit is not necessary, as I have checked colleagues PCs with the same set up and it works fine.

@Marcel_Rijsmus But the file path is fine, its just shortened (automatically by Dynamo).

I have also just done the same test in Dynamo 2.0 with the same issue.

If anyone has any other suggestions, please let me know! Otherwise I am strongly considering factory resetting my computer and re-installing everything again (which I would prefer not to waste time with)

Thank you

Jacob, I have recently re-tried and CSV now works again. But Excel does not. Another plugin within Revit i recently used tried to access excel and couldn’t due to something like Excel.Interop.Application error. Any ideas?

Thank you

My guess: you need to update to a 64 bit version of excel.

Thank you. I have checked on a colleagues machine with 32bit Excel and it works no problem… Is a full reset my only option?

Not your only but likely the fastest fix.

Why are you using 32 bit?

All & @JacobSmall,

Thank you for all your assistance. My computer recently did a Windows update to Build 17134 of Windows 10 Pro, and now it works!! Phew :grinning: