Error - specTypeId is not a measurable spec identifier?

Hi @scott.tomlinson - The Revit API changed the way parameters were accessed and set, and unfortunately we missed this interaction :frowning: So sorry about that. It is currently being fixed.

In the meantime, you can do one of the following:

  1. Either convert your existing 0’s and 1’s to False and True respectively, which will mean your graphs will work in any version of Dynamo.
  2. Temporarily put in a converter - code below :slight_smile:

num == 0 ? false :
num == 1 ? true :

Hi @solamour ,
Thanks for your reply… Strange I though I had tried that with the true/false prior to posting, but with no change. It has now solved this situation (thanks!), BUT…
the second situation which requires an integer to set the Titleblock scale bar is still having no success. Do you have any tips for how to fix this one?

@scott.tomlinson are you able to provide me with the family to check :slight_smile: ? Feel free to upload here if you are comfortable, or direct message me.

Hi @solamour … with pleasure.
Just for reference:

LMA_Annotation_TitleBlock_A3_SKETCH.rfa (584 KB)

Hi @solamour,
Just by way of an update, I’ve tested further, and the problem appears to be setting a family parameter which requires an Integer value. I created a simple Generic Annotation family with an integer based instance parameter, and the same error is returned. No error is returned on number, yes/no (etc…) parameters only those requiring an integer.
Would you know the cause / solution to this. If it is a Dynamo v2.13 (+?) will this be resolved in future releases?

Hello @scott.tomlinson - This has now been resolved for Revit 2023.1 and Dynamo 2.15, and will also be hot-fixed back to Revit 2023.0.1 along with a bunch of other bug fixes in Revit.

Unfortunately I cannot gives dates on this, but the hotfix should be coming out relatively soon :pray: So sorry for the frustration on this one.

As rightly noted, it’s a generic problem that had to be remedied inside the Unit Converter class: fix the issue revit-191624 (#2826) by wangyangshi · Pull Request #2846 · DynamoDS/DynamoRevit · GitHub

Hi @solamour,
Ah… good to know that it wasn’t user-error on my behalf :slightly_smiling_face:
Thanks again for the prompt feedback - much appreciated.

1 Like

Hello @scott.tomlinson - as per 📢 Dynamo 2.13 - Revit 2023 Set Parameter Issue(s) - Hotfix Out Now you should now be able to download the hotfix and have this resolved :slight_smile:

1 Like

Hello @solamour … unfortunately even with the Hotfix installed, the problem persists (unless I’m doing something wrong).


Oof, ditto. Assume this works in the developer’s tests for Dynamo build, so maybe something got missed in the hotfix deployment?


Have a look at the solutions above.

1 Like

Yes the problem is now that the fix was meant to have been patched. Doesn’t seem to have been unfortunately, or we’ve both installed incorrectly. Autodesk app was my method, so figure it was correct.

I also installed via the AD Desktop app.

Hello all - I just installed the update myself and am seeing the same issues you guys are seeing :sob: I’ll reach out to the team in question and investigate. The PR was merged (code fix) and the case I just tested that failed, was working at that point in time.

1 Like

hi Scott, which Revit 2023 hotfix version are you using? Is it Revit 2023.0.2 (build 20220726_1500), released on Aug. 3rd?

Hi @gina.liu, I believe so…

We’re looking into a proper fix now - it appears, as Gavin mentioned above, to be an installer build issue. We’re working on properly identifying how to resolve this issue :pray:

WARNING: Dangerous approach to use at your own risk below...

If you want to be adventurous and live on the edge, you can replace the DynamoNodes.dll attached here inside your DynamoRevit installer.

This comes with a few caveats:

  1. We take no responsibility for any problems that occur should you choose to take this action.
  2. If something goes wrong and breaks, it may cause you to have to reinstall Revit. Theoretically it shouldn’t.
  3. This didn’t blow up my install and worked perfectly fine, but there have been issues in the past.
  4. Take a copy of your existing RevitNodes.dll just in case and place it somewhere safe, so that you can put it back if needed.
  5. To attach to the Dynamo Forum the .dll file been renamed into a .txt file, so you’ll need to rename it back to simply RevitNodes.dll for Dynamo to recognize it.
  6. The attached RevitNodes.dll contains the fix, and will unblock the problems in this thread.
  7. After downloading the RevitNodes.dll make sure to right-click on the file, go to Properties and unblock it so that Windows will trust the file and allow it to be read.
  8. Your RevitNodes.dll will live under C:\Program Files\Autodesk\Revit 2023\AddIns\DynamoForRevit\Revit

RevitNodes.dll.txt (386.5 KB)


Thanks @solamour …Works great, the only thing i just will mention is
8. remember unblock the file :wink:


Good shout! I’ll add that to the steps :smiley:

1 Like

Thank you Mr. Wizard. I followed your instructions and it works perfectly! My best wishes to you.

1 Like