Elements Set Parameter By Name Type Or Instance Error

I’m having an issue with the Elements.SetParameterByNameTypeOrInstance node suddenly and I’m stumped on why and how to fix it. I’m trying to set some parameters to elements in a group, and it was working fine a week or two ago, and today I’m getting an error about an ambiguous call. I have tried the Element.SetParameterByName node and it comes back stating that there is no parameter found by that name. Any thoughts / solutions?

Thanks :beers:

SetGroupElements-IsUnitGroup.dyn (43.5 KB)

Do you have a sample RVT that reproduces this too? The ElementWrapper warning is a weird one that happens when Dynamo is a bit confused.

What object types are you sending in?

Also, that seems like probably a bool parameter and not a string.

Try putting in a bool true node.


I’ll see if I can put one together that does it. I’m fairly certain I ran the graph on the project that is having an issue not long ago, so I’m not sure what happened.

The graph take the model group and assigns the value to elements in the group. Off the top of my head- walls, doors, casework, plumbing fixtures, ceilings, probably one or two others.

It actually is a text string since Yes/No parameters can’t vary by group instance :roll_eyes: I just have the filters set to Yes. The string value could be anything really.

Pretty sure the additional elements in the API Path of Travel are causing a wrapper hiccup. Not that you are using that element type, but Dynamo is trying to wrap something that it does not understand and it is surfacing that error.

What element types are you feeding in exactly?

@john_pierson sorry about that- I got distracted and this hit the back burner for a bit.

After a bunch of testing I figured out that I can reproduce the error if I have a curtain wall element in a group that I’m trying to process. I don’t know if any other categories will react the same way, but that seems like a good starting point for error checking. It appears to still set the parameter value for the curtain wall, just with that wonky error.

1 Like