Editing Revit Type Names with Dynamo through excel


Some time ago I create a dynamo script to change the name of revit families through excel. Now it doesn’t work anymore, and I don’t know if it is due to the dynamo upgrade to dynamo 10 (I create the script with dynamo 9 and a clockword node) or another thing. I will apreciate any kind of help. Thank you.

Hi Carles,

What does the error says? Can you show watch node on “Success” and “Fail”.

No error appears, it just doesn’t work, and it used to. Maybe there’s something wrong with the clockwork node “Element.Set.Name”.

Are you using the same revit version which “Element.SetName” used to work?

Yes, and I tried with other versions of revit. What it changed is the version of Dynamo. It used to work with dynamo 0.9 but no with dynamo 1.0

@Carles_Briz - I’m in the process of migrating Clockwokr to Dynamo 1.0 but this may still take a couple of weeks as I currently don’t have a lot of spare time and I still have about 25% of the nodes to process.
Element.SetName is one of the nodes that I haven’t looked at yet.
I have filed a bug for it here: https://github.com/andydandy74/ClockworkForDynamo/issues/105


Thank you @Andreas_Dieckmann

@Andreas_Dieckmann Did you migrate the node “Element.SetName” to dynamo 1.0? Because now it works well. If so, thank you very much!!!