Dynaworks node not getting all properties

Hi there. I’m using Dynaworks to try to extract properties from Navisworks models (mainly Revit and Civil 3D) using “NavisPropertyList.GetValuesAsStringClassUserName” node, but every time I run the code, some items are not read correctly, returning empty values in their indexes. What puzzles me, though, is that I couldn’t find a pattern in what items are extracted or not. I attached a image showing the code. The code read 183 items in all Select Sets in the model, but only read 164 IDs from those items. In other extractions, other IDs aren’t read, and sometimes all the IDs are read. This happens with any property, and any project from different applications (Revit and Civil 3D). Any suggestions are appreciated. Thanks.

capturar1

@Gytaco ? Any tips?

This can be an issue with the Navisworks Hierarchy which can be really messy. Are you sure the Attribute object you are selecting is grabbing the right level to access the Element ID? Are you getting the ID’s from clashes or selection sets?

Adam, I’m getting the IDs from Selection Sets. The hierarchy is correct, and the properties I’m trying to get are, too, as the data extracted is correct. The thing is, every time I run the code, some random properties aren’t read. If I run the code five times in the same model, the missing data is different. Also, sometimes all the data is read, and I couldn’t find a reason why, since I didn’t do anything different. I tested with different models from different applications, and different selection sets, and this behavior occurs in all of them.

I’m attaching the whole code, maybe I’m missing something. Thanks.

Hi @AndreBarrozo

Please show us watch node or preview bubbles for all the nodes. Thanks!

Hi Kulkul,

These are the results of three different extractions made one after the other, with me just closing the code and reopening it again.

In the first extraction, notice there are 228 nodes (elements) in the Select Set (there is only one in this model). However, only 221 IDs were extracted at the next node. In the preview panel, you may see, for example, item #25 wasn’t extracted, and created an ‘Empty List’ entry in the list.

In the second extraction, apparently the same 221 IDs were extracted. However, when we look at the preview, we see that the item #25 has its ID extracted, different from the previous extraction. I didn’t print the rest of the list, but another 7 different values weren’t extracted.

Finally, in the third extraction, not only the number of extracted IDs are dfferent, but also the values not extracted has a ‘null’ value, a little bit different from the ‘Empty List’ value we’ve seen on the first extraction. Also, this node popped a warning, albeit not very helpful.

As you may see, the missing elements are completely random - I couldn’t figure any pattern on this behavior.

Thanks,
André

capture2

Would you be willing to share the file for checking? My guess is it’s the hierarchy of the selection tree but without the nwc/nwd I’d just be guessing…

Feel free just to isolate the particular offending items within revit and just export to a Navis file.

Hi Adam,

Sorry for the delay, I was on vacations.
I sent the shared files by e-mail, but if anyone else is interested, I’m also sharing the link here:

https://drive.google.com/open?id=0BxyECVTHyAkQODZyeTRWS3VqUEk

Thanks,
André