DynaShape


#84

This is likely because the default value for the “constant” input is not working properly (Some users have reported this type of issue)

It is very easy to fix: Just manually input a vector into the “constant” input. In this case, you should use the vector value (0, 0, -0.1) because that is this default value for “constant”


#85

Works perfectly! thanks a lot :+1:


#86

Im having the same issue.

Did you find a way to fix it???


#87

Yes try to re install and solve it, the issue was teh xml file

Thanks Long great packages


#88

Hy LongNguyen, first of all I have to thank you for your great contribution. It’s simply fantastic…
Right now I’m reading a bit about Form Finding and optimization applied to structural engineering. And, of course, your package is very useful.
I only have one question: What method do you use to determine the equilibrium surface? Is it the force density method or some other? I would like to understand the bases.
At this moment I have not read the code. But I will soon.

Thanks a lot


#89

And another question: Do you can create a installation document for Dynamo 2.0?


#90

I did that and don’t work


#91

Hi Long,

I am an architect very keen to try out DynaShape.

However I am having problems installing it and I have tried everything I can imagine. I have carried out all the instructions as per your installation post. Please help. See screen shot.

DynaShape appear in Dynamo under packages > installed packages but it does not appear in the library. I have tried everything and I am stuck.

Any help would be appreciated.

Thanks in advance.
Ray


#92

Have you used the installer package or have you done some manual file placement? This has worked very recently for me with no issues.
The installer was from the link @LongNguyen provided at the start of this topic
http://bit.ly/2w3nD0k


#93

Hi Felix. The equilibrium is essentially achieved using an iterative error minimization algorithm that works very similar to Jacobi method for solving over-constrained system of linear equation.

The mathematical framework is described in this paper http://lgg.epfl.ch/publications/2012/shapeup/paper.pdf. As I am aware, Kangaroo2 for Grasshopper is also based on this paper.

The implementation in DynaShape, however, does not use matrix notation as in the paper. Otherwise it will be quite tricky for users to define custom goals/constraints.

I am still working on the next DynaShape release, which will be compatible with Dynamo 2.0


#94

Looks like you are using Dynamo 2.0. I will release the next update soon, which will be compatible with Dynamo 2.0


pinned #95

#96

DynaShape for Dynamo 2.0 is now released. Please see the first post :smiley:


#97

:+1:


#98

This looks amazing but as I still have to deal with Revit 2015 files I’m stuck with Dynamo 1.2.1.

I’m guessing DynaShape simply does not work for any Dynamo version older than 1.3, am I correct?


#99

Hmm I think it should possible to use Dynamo 1.3 with Revit 2015. You just need to upgrade the Dynamo core to 1.3

Dynamo 1.2 has a bug that affects DynaShape. This is why 1.3 is needed.


#100

I expected so.
But, at least in theory, Dynamo 1.3 doesn’t work with 2015 (hope all the 2015 projects will be done soon :expressionless:).
I’m in no haste to use DynaShape but it does look pretty amazing to try out.


#101

Is this resolved now?


#102

If the installer does not work for you, you can try the manual installation method (see the first post)


#103

I tried it but it doesn’t work either.Also I noticed that there are no dyf files in the package folder of manual install.
is it not required ?